Community
Showing results for 
Search instead for 
Do you mean 
Reply

HTTP 500.19

Accepted Solution Solved
New Member
Posts: 3
Country: Switzerland
Accepted Solution

HTTP 500.19

Hi

 

I get following error message, if I press the TEST Button on the Web Site Administration within ACT!

 

"IIS 8.5 Detailed Error - 500.19 - Internal Server Error".    The rest is not visible because on the error page from ACT! is no scrollbar to see what else is written in the textbox.

 

Constellation:

  • Act! Premium (Web) Version 18.2.53.0, Update 4
  • Server 2012 R2
  • Act! started with admin rights on the server
  • IIS 8.5

On the IE I get following error after typing http://localhost/apfw

 

HTTP Error 500.19 - Internal Server Error

The request page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information:

Module: IIS Web Core

Notification: BeginRequest

Handler: Not yet determined

Error Code: 0x80070021

Config Error: Lock violation

Config File: \\?\C:\Program Files (x86)\ACT\Act for Web\APFW\web.config

Requested URL: http://localhost:80/apfw/

Physical Path: C:\Program Files (x86)\ACT\Act for Web\APFW\

Logon Method: Not yet determined

Logon User: Not yet determinded

 

Config Source:

546:  modules runAllManagedModulesForAllRequests="true"

547:      remove name="StaticCompressionModule"    RED marked

548:      remove name="WebDAVModule"

 

There is an entry in the Knowledge Database about  the error 500.19 with the Answer ID 26008 and i tried to solve it according the instruction, but it didn't work.

There must be differences between IIS 7 und IIS 8.5.

 

Does someone have a solution.

 

Thanks

Wolfgang


Accepted Solutions
Solution
Accepted by Gary W (Administrator)
‎05-05-2017 06:34 AM
New Member
Posts: 3
Country: Switzerland

Re: HTTP 500.19

After reinstall of the ASP.NET and reinstall of ACT (WEB)  (2 times) the problem was solved.

 

I don't have any error messages and i can start ACT over the web link.

 

Thanks for the idee to reinstall ASP.NET again.

 

Wolfgang

View solution in original post


All Replies
Moderator
Posts: 451
Country: United_Kingdom

Re: HTTP 500.19

Hi Wolfgang,

 

Would you be able to tell me which test button provides this error (ASP.NET/Impersonation/Add Remove database)

If this is failing on the first or second tab, could you hold CTRL and click on the next tab along as this will allow you to skip the step, as Act in some environments can throw some red herrings.

It may also be worth reinstalling ASP.NET in case this has been corrupted in some way.

 

If you do not already have it I have included our Web Admin Guide: Act! Premium Web Administrator's Guide

New Member
Posts: 3
Country: Switzerland

Re: HTTP 500.19

Thanks Horn,

 

The result i got was, as i tried to open ACT within the Internet explorer.

 

i just reinstalled ASP.NET on the server and started ACT again. I have the same result.

 

On the Web Site Administration in the first tab (Web Server) with the button Test i will get these message. It shows only the first part, because it's not possible to scroll within the error message.

 

see attached PDF.

Solution
Accepted by Gary W (Administrator)
‎05-05-2017 06:34 AM
New Member
Posts: 3
Country: Switzerland

Re: HTTP 500.19

After reinstall of the ASP.NET and reinstall of ACT (WEB)  (2 times) the problem was solved.

 

I don't have any error messages and i can start ACT over the web link.

 

Thanks for the idee to reinstall ASP.NET again.

 

Wolfgang

Administrator
Posts: 4,024
Country: United_Kingdom

Re: HTTP 500.19

Hi Wolfgang,

Thanks for letting us know how you solved the issue.