Community
Showing results for 
Search instead for 
Do you mean 
Reply

Getting Database cannot be accessed message as if I have a network connection - I don't

Highlighted
Copper Contributor
Posts: 14
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

Apparently there are a number of us that are experiencing the same problem that you are experiencing in different versions of ACT!.  I am using Vista OS.  Unfortunately the only answer I have is to check your MS updates to see if SQL service pack 3 and any updates are failing to install. 

 

I did a system restore back to a point where ACT! worked properly.  Afterwards, I disabled automatic updates. This, of course, meant that SQL will not be updated but I will be able to use ACT!.  At this time I am also awaiting a solution to this or a very similar problem. 

 

I have thought of uninstalling ACT! .  Then installing SQL service pack 3 and the subsequent updates and then reinstalling ACT!  The problem is that I don't have the guts to do it in fear that I will not be able to reinstall ACT! because of the SQL change.  Unfortunately, at this time my small business depends on my ability to use ACT!.

Highlighted
New Member
Posts: 3
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

I am having the same set of problems. It seems to be related to the SQL server. I have uninstalled and reinstalled everything. Now I cannot open my database. I don't use a password, but it asks for a password. Does not accept no password and does not accept my old password, which I am sure of. I used it for years.
Highlighted
New Member
Posts: 11
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

Exactly! After troubleshooting every morning for the last few days, I am happy to wait for an answer of ACT/SQL-SP3 working properly together before I attempt the SP3 patch again.
Highlighted
New Member
Posts: 11
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

Issue seems to be in Microsoft's patch:

 

http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/c4eab182-6e48-42ce-8f67-319bf2be0129

 

I'll wait for this to be corrected before trying to install.

Highlighted
New Member
Posts: 3
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

It looks like I have my ACT 11 working again. I stopped Windows automatic updates - since it is stuck trying to update SQL - and reinstalled everything which was an all-day project. I had to uninstall ACT (don't know if I had to, but I did), then uninstall the five SQL related programs, then delete the folder in Program Files for SQL. only then could I reinstall everything. Something like that. It took many tries - trial and error.

 

I am pretty disappointed with Microsoft and Sage. Somebody should have seen this coming.

Highlighted
Copper Contributor
Posts: 14
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

You have attention.  Are you Vista or XP?  Let me try to understand what you did.

 

1)  You un-installed ACT.

2)  Un-installed 5 SQL related programs (Where are they located? In Program Files? Are the files specifically named "SQL Files"?)

3)  Deleted the folder in Program Files for SQL.

4)  Downloaded and re-installed SQL service pack 3 and subsequent updates.

5)  Re-installed ACT!

 

Did you back up your database files or did you leave them alone while you did these changes?  Did I miss anything?  Do you see any appreciable differences in speed, programs, etc.?

 

I really appreciate your input.

 

Highlighted
New Member
Posts: 3
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

I'm sorry I wasn't more specific. I have Win XP on a Toshiba laptop with 2gb of memory, dual core Intel...

 

I used Control Panel - Add/Remove programs to remove Act, then Microsoft SQL (there are four) plus another. 

Then deleted the folder related to SQL in Program Files.

Then re-installed Act, which installed SQL, but the SQL part got stuck and didn't take. 

So I used a utility in the Act installation folder (I downloaded Act 11) to install only the SQL. That only works after Act is installed, so that has to go first. 

 

It had been slowing down and then getting stuck a week ago. Now it works well, like it used to. 

 I think I did more than what was necessary, but I had started all that when I discovered the problem has to do with MS Windows update getting stuck trying to update the SQL server. Stopping that was key (disabling automatic updates). That's where you should start. Then see what works after that.

 

I hope this helps. 

Highlighted
New Member
Posts: 1
Country: United States

Re: Getting Database cannot be accessed message as if I have a network connection - I don't

I am having the same issue. Just installed a new hard drive. Installed Act Premium 7. I see the databases. I am a stand-alone computer and never changed any sercurity settings. I've never had an issue like this when I bought a new computer. Was always able to open my databases. I already checked the SQL settings as noted and went through all the troubleshooting tips for a local computer on the Act web site.