Showing results for 
Search instead for 
Do you mean 

Four failed install attempts and a success

New Member
Posts: 1
Country: USA

Four failed install attempts and a success

software:  Sage ACT! Pro 2011 (on DVD)

Installation Problems .... finally succeeded

This began as a log for tech support to debug a failed install,
but after my install succeeded,
decided to post it to help other users who may be in a similar fix

    About a year ago, installed Act 2010 on a trial basis.
    It ran OK, but I didn't have time to do development.
    The trial period expired.

    This week, purchased Act 2011 Pro on a CD.
    New, standalone  (not upgrade)

    Since Act 2010 was never used, there was no data worth saving.

Before this installation attempt
    a) uninstalled Act 2010 via Control Panel / Programs
    b) then deleted whatever remained in "c:\programs (x86)\act\act for windows"
    c) then deleted "user account\my documents\ACT"
    then tried to install Act 2011

Install try #1)
    "Running System Check ..." proceeds for a minute,
then hangs about 90% of the way along the progress bar.
Stayed at 90% progress for 15 minutes before I closed the windows and forced a system restart.

It appears stuck in an endless loop ....
CPU Performance cpu 1 about 80%, cpu 2 about 25%, cpu 3,4 near zero

ACT! did not install.

Install try# 2)
Checked the User Community notes for a similar problem.
Several messages recommended (for Act 2010 and earlier),
use the task manager to end the process  "prereq.exe"

The result was a popup message:
"Sage ACT! has detected an ACT7 instance that could not be connected successfully.
Either you have entered incorrect password or SQL service may not be running.
The installation cannot continue at this time.
Please run the installer again and provide a valid password or make sure that SQL (ACT7) instance is running and then continue installation."

ACT! did not install.

Install try# 3)
tried following this advice:
copy all of the dvd to a temp disk folder,
and rename the prereq sub-folder to something unexpected like prereqtemp

it ran for a while
then sticks on "Computing Space Requirements" at about 90% progress

Installer generates a message:
    Invalid Drive R:

followed by
    Error: -1603 Fatal error during installation

ACT! did not install.

Install try# 4)
    ran Act_Uninstaller.exe (version 13.0)
    MUST right-click, "Run As Administrator"

checked the uninstall log file
it did not delete
because "files were present"
I manually deleted all the files.

Performed install of ACT using disk storage  (same as try #3)

it proceeded - hung for a while on "computing space requirements"
then picked up again and successfully installed

ACT! installed.



(Actually, there were more installation attempts than above, with other variations)


The moral here appears to be  too much digital rights management (DRM)

and too much complexity in the Windows Registry database.

It cost me, a legitimate user, a technical knowledgable computer user,
10 hours of my time (over 3 days) to look for solutions, and experiment, just to install the @(*#!(^ thing.

That significantly raised the true cost of this program.

ACT would be more reliable if it reduced its dependence on the Windows Registry and simplified its installation.

Good luck one and all ....

    recent system, a year old
    CPU Intel Core i5
    6 GB memory
    400 GB free disk

    Windows 7 Home Premium, 64-bit
    Microsoft Office 2007
    Norton Internet Security 2010
    (above software with all current patches)

    System is connected to internet, but not part of a local network.

Bronze Contributor
Posts: 955
Country: Australia

Re: Four failed install attempts and a success

I had a similar problem and enabled the Administrator account whihc then allowed the installation. May be an easier option to try in future

Paul Buchtmann Australia
Australia's First ACT Consultant (1989)

FREE Record History to change default to Call or To-Do for ACT! 2010-2012 versions. Custom versions also available.
Bronze Super Contributor
Posts: 1,170
Country: USA

Re: Four failed install attempts and a success

This is not so much a design flaw of Act! as it is of the Windows OS...


A significant portion of what you install when installing Act! is not Sage code - it is Microsoft code (SQL server, .NET, etc.)

New Member
Posts: 8
Country: USA

Re: Four failed install attempts and a success

Had the same issue, thanks for your postings.  Unfortunately ACT Uninstaller v14 didn't work for me as it didn't find anything to uninstall.  I manually cleaned up the system before seeing your post.


What I noticed was while the installer was hanging about 90% through the checking system phase, I pulled up the task manager (with out stopping the install process) and ended the process  "prereq.exe".  The install process took off from there and completed a successful install.