Community
Showing results for 
Search instead for 
Do you mean 
Reply

Failed to setup remote sync entity. Main database is inactive for sync.

Copper Contributor
Posts: 26
Country: USA

Failed to setup remote sync entity. Main database is inactive for sync.

I have two main databases, one for reps and one for execs.

 

Rep remote DB's sync fine, execs remote DB displays above message when attempting to sync.  Both DB's are located on the same server, both main DB's are added to the sync service.  All PC's have network connectivity. 


Where do I go from here?

 

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

Please provide some additional information about your issue:

- Version of Sage ACT!?

- Operating systems involved?

- Does anyone else successfully sync with the Exec main database?

- Is synchronization enabled for Exec main db, through Tools > Synchronization panel?

 

If this is Sage ACT! 'Pro' > sync will only occur when main database is open.  If the Rep database is open on server, the Exec sync will not be possible.  Conversly, if Exec db is open - Rep will not be able to sync.

 

 

Greg Martin
Sage
Copper Contributor
Posts: 26
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.


gmartin wrote:

Please provide some additional information about your issue:

- Version of Sage ACT!? Premium SP1

- Operating systems involved? Server 2008 R2 and Windows XP SP3

- Does anyone else successfully sync with the Exec main database? Currently only one user with the exec database.

- Is synchronization enabled for Exec main db, through Tools > Synchronization panel? Yes

 

If this is Sage ACT! 'Pro' > sync will only occur when main database is open.  If the Rep database is open on server, the Exec sync will not be possible.  Conversly, if Exec db is open - Rep will not be able to sync.

 

 



 

Copper Contributor
Posts: 26
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

Bump!

 

You can have more than one main database set to network sync, correct?

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

In the problem publisher database, check the synchronization status.  This is done by:

- open database

- click Help > select About ACT!

- click Database Information

- scroll down to locate 'Sync Enabled' and 'Sync Role', they should be set to 'True' and 'Publisher'

Is that what you find?

 

Yes, you can have more than 1 database set up through Network Sync Service.

 

Greg Martin
Sage
Copper Contributor
Posts: 26
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

Published database is set to True and Publisher.

 

Subscriber database is set to True and Subscriber.

Copper Contributor
Posts: 26
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

Any help would be appreciated!!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

To help isolate where the issue is:
Create 2 new remote databases, restore one on the current workstation with problem remote, and the other on a different computer > attempt to sync them. Do they both succeed, both fail, one succeed/one fail...

If they both fail, the issue would appear to be with the main database.
If they both succeed, issue appears to be with the original remote.
If remote on original workstation fails, and remote on 'different' computer succeeds - the issue appears to be with the computer.
Greg Martin
Sage
Copper Contributor
Posts: 26
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

Created two remotes from original database.  Workstation giving errors continues to give errors, but successfully syncs with remotes from other main databases.

 

Second remote syncs successfully on second workstation, in this case this is the local server hosting the main database.

 

However, remotes from other main databases do sync successfully on the original workstation. 

 

So I took the successfully syncing remote, and moved it to the problem computer through the wizard.  It gives the following error.  ACT is unable to connect to the sync server.  Check to make sure accept incoming syncs is enabled and that the network sync service is running.

 

Obviously, it's connected to the network.  It successfully pings the server by name, and likewise the server pings the machine by name.  The database location was changed to match the new location. 

 

 

Copper Contributor
Posts: 26
Country: USA

Re: Failed to setup remote sync entity. Main database is inactive for sync.

Created another new remote and restored on the troubled workstation, it successfully syncs.  Go figure!