Community
Showing results for 
Search instead for 
Do you mean 
Reply

Errors Trying To Start Email With Outlook 7

New Member
Posts: 12
Country: USA

Errors Trying To Start Email With Outlook 7

Dear Sirs:

 

I am using Sage ACT! Pro 2012 Version 14.1.108.0.

 

I am trying to send an email through ACT! by clicking on the email address in the contact screen.  I have Outlook open when I do this.  I get either of the following messages:  "The RPC server is unavailable. {Exception from HRESULT: 9x800706BA)"  or "Object reference not set to an instance of an object."

 

I have run the Office 2007 diagnostic tool and it tells me there is nothing wrong with the Office 2007 product.

I have uninstall ACT! and reinstalled ACT! and it does not seem to help!

 

I have followed the advice in Knowledgebase on "Object reference not set to an instance of an object."  but this also has not helped.

 

Does anyone have any suggestions?

 

Scott Pyper

Arizona

Copper Elite Contributor
Posts: 257
Country: Australia

Re: Errors Trying To Start Email With Outlook 7

[ Edited ]

Hi Scott

 

You might like to try running through this this KB Article 24781, it lists a few other possible solutions.

 

Could also be a damaged normal.dot template.  Refer to this KB Article 

 

Cherie Buttsworth
ACT! Certified Consultant
Simply PC
cherie@simplypc.com.au
New Member
Posts: 12
Country: USA

Re: Errors Trying To Start Email With Outlook 7

Thanks for those suggestions, Cherie!

 

1)  Tried deleting the normal.dotm file to no avail.

2) Office Word will open a email window when I click on the ACT!  contact email as long as the Outlook is not running.  This is strange because I believe one must have the Outlook running for it to work normally. 

3)  When I have Outlook open and I click on the email it takes about 10-20 seconds for me to get "object reference not set to an instance of an object."  error message.

4) I tried uninstalling ACT! along with SQL 2008 and the associated programs and this didn't provide a solution.

5) I tried uninstalling Microsoft Office 2007 Professional and then reinstalling it and this did not provide a solution.

6) I am really running out of things to do so I may be FORCED to buy the 2013 ACT! just so I can get the technical support to fix it!

7)  upgrade is $150 and one issue of technical support is $100 so gotta upgrade I suppose.

Copper Elite Contributor
Posts: 257
Country: Australia

Re: Errors Trying To Start Email With Outlook 7

Ok, lets recap..

 

1. Did your rename all the normal.dotm files to old and then open word so it creates a new normal.dotm file?

2. Office word opens an email? ?  Or Outlook opens the email when clicking the email hyperlink in ACT?

3. Is Object reference not set to an instance of an object now the only error message you now receive?

3.  What version of windows are you running?

 

Cherie Buttsworth
ACT! Certified Consultant
Simply PC
cherie@simplypc.com.au
New Member
Posts: 12
Country: USA

Re: Errors Trying To Start Email With Outlook 7

1) there is only one normal.dotm (normal.dotm is the correct file I believe for this version of Office) file found in Office 7 Professional.  I deleted it and then opened Word again in order for it to create a new one.

2) I believe Outlook  is supposed to open a Word email dialog box  when Outlook is selected as the email vs. Act email -- right?

3) If I have Outlook closed and click on the email hyperlink on the ACT! contact screen, it will open the Outlook email dialog window which seems fine.  If I have Outlook opened on my computer and try clicking on the hyperlink email I get "Object reference not set to an instance of an object."

4) If after closing the Outlook email dialog box after it initially opened correctly,  I try to click on the same email hyperlink a 2nd time I get a new message which is:  "The RPC Server is unavailable. {Exception from HRESULT: 0x800706BA).

5) This is the sequence of events that I experience.  I don't particularly want to have Outlook closed each time in order for me to send an email via ACT. That is a terrible nuisance.

6) I am running Windows 7 Professional 64 bit Service Pack 1 with 18 gig of RAM.

 

Copper Elite Contributor
Posts: 257
Country: Australia

Re: Errors Trying To Start Email With Outlook 7

If Outlook is your configured email program within ACT, then clicking on the hyperlink should open a new Outlook email message (As it does, when you have outlook closed) not word.

Do you have your User Account Control turned off in windows?

 

Also, do you have the the current HotFix for 2012 SP1?  Not that I think it will magically solve your issue, but its always best to start with the most up to date patches as possible.  I believe it should be hot fix 4.  If you Don't have hotfix 4 installed, please see this KB Article on how to download and install it.

 

 

Cherie Buttsworth
ACT! Certified Consultant
Simply PC
cherie@simplypc.com.au
Bronze Super Contributor
Posts: 1,679
Country: Australia

Re: Errors Trying To Start Email With Outlook 7

Likely already tried this, however Smiley Happy

Start | run | cmd <enter>
cd /d c:\program files (x86)\act\act for windows <enter>
act.outlook.repair.exe <enter>

Retest and see if it's still a problem.

New Member
Posts: 12
Country: USA

Re: Errors Trying To Start Email With Outlook 7

Hi Ben,

 

I did try the outlook repair in the DOS window but it didn't help -- but thanks!

 

New Member
Posts: 12
Country: USA

Re: Errors Trying To Start Email With Outlook 7

The anomoly is that when Outlook is closed and I click on the email hyperlink inside of ACT! Pro 2012  it works.  However, I would like to keep Outlook open at the same time I have ACT! running.  When Outlook is open, I get the error message:  "Object reference not set to an instance of an object." 

 

If I close the successful email window that opened while Outlook was closed and click on the email hyperlink a second time just to see what happens I get:  "The RPC server in unavailable..."

I did go into Control Panel and click on Folder Options to change to SHOW folder and found the Normal.dotm (Windows Office Pro 2007 version).  I deleted it again and emptied it from the Recycle Bin and then opened Word and it opened just fine.  I then closed Word and opened Outlook and then clicked on the hyperlink email in the ACT! contact screen BUT, alas, got the same message, "Object reference not set to an instance of an object."  Incidentally, before I uninstalled Office I ran the diagnostics and it said Office was perfectly fine.  So, uninstalling Office and reinstalling Office evidentally was not necessary but I had to eliminate that possibility.

 

I am not sure what "User Account Control" is, however,   I am the sole user of this computer or the Administrator.

 

I had thought that the Sage ACT! Pro 2012 SP1 was the latest version for the non-premium, non-web version of 2012.  Do you have a link to the hotfix 4? 

 

Current Version:  Sage ACT! Pro 2012 Version 14.1.108.0

 

Thank you!

 

 

New Member
Posts: 12
Country: USA

Re: Errors Trying To Start Email With Outlook 7

Regarding any hotfix update when I click on help/ACT update I get "You already have the latest version of ACT!" so I'm not sure where I should find a hotfix to SP1.