Community
Showing results for 
Search instead for 
Do you mean 
Reply

Error when converting from earlier version - protected memory error

New Member
Posts: 1
Country: UK

Error when converting from earlier version - protected memory error

Hi,
 
I have been trying all day trying to get the following problem solved.
 
Action: Installed ACT!2007 and trying convert old V.6x database.
 
Problem :
ACT!2007 installs OK with no errors. Program runs and takes me through the conversion wizard. It starts converting the data and completes the first step of 'Updating the ** database', it then starts 'Updating contacts'. It will get part way through this stage and then give the following error:
 
Attempted to read or write protected memory. This is often an indication that other memory is corrupt
 
It then quits the conversion and gives a warning that it cannot open the database (obviously as it doesn't yet exist).
 
Things I have tried:
I have tried on 3 different machines 1 x SBS2003 server and 2 x XP machines, all give the same error.
The SBS2003 machine never had the previous version installed, the other 2 did but I uninstalled prior to installing new version.
I have followed the advice of GLComputing in thread http://community.act.com/sage/board/message?board.id=ACT&message.id=612
Within that i have used the Uninstaller in KB19338 and on a second attempt manually using KB14499
I have been through various MS articles changing settings using DCOMCNFG
According to one article the problem *could* be fixed with SQL 2005 SP2 but I cannot install this on the ACT!2007 instance as it has different credentials so won't install.
 
Has anyone come accross this particular occurance of this error? My next thoughts are to try installing on XP no-sp machine, or getting Sage to upgrade the DB for me and do a database restore.
 
Any suggestions?
 
Thanks
Dan
Nickel Super Contributor
Posts: 441
Country: UK

Re: Error when converting from earlier version - protected memory error

This is nearly always an our of resource error on the server - if you have a more powerful machine availble try it on that.  If you need someone to convert if for you have a look at our website www.rowcol.co.uk
 
Tom
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Error when converting from earlier version - protected memory error

It might be damage in the ACT! 6 database. Can you try it on the ACT! 6 demo database?
New Member
Posts: 1
Country: Australia

Re: Error when converting from earlier version - protected memory error

[ Edited ]

Hi Dan,

 

This may be a little bit late for you (maybe it will still help others?) but I had a similar issue and it was resolved by double-checking the original data first. I did get a conversion to work after nearly a month and then discovered that I had one email address with more then 1 "@" symbol. I removed that and then everything worked a lot better. I cannot say for sure how this fixed the issue but we are now running a lot smoother with a clean database and a second attempt to convert this old one was successful first go.

 

I hope this helps?

 

See ya

Message Edited by kwildermoth on 08-03-2008 08:49 PM