Community
Showing results for 
Search instead for 
Do you mean 
Reply

Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

Accepted Solution Solved
New Member
Posts: 2
Country: United States
Accepted Solution

Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

Hello all,

 

We have a few fields that are assigned as "Currency" with 6 spaces to the left of the decimal point and two spaces to the right of the decimal point.  I need to be able to type in three spaces to the right of the decimal, for example: $.145.  I keep receiving the error, "Combined field lengths have exceeded the maximum for the database table. Resize or delete other fields before increasing the length of this field." 

 

I tried to shorten/resize some other fields, but was given the same error .... even though I was trying to shorten a field.  Any ideas? 

Thanks much!!!

 


Accepted Solutions
Solution
Accepted by dlunceford (Moderator)
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

Please see if this Knowledgebase Article helps resolve the issue.  If your version of ACT! is 2007 or above, then just type "actdiag" to open the diagnostics tool.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Solution
Accepted by dlunceford (Moderator)
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

Please see if this Knowledgebase Article helps resolve the issue.  If your version of ACT! is 2007 or above, then just type "actdiag" to open the diagnostics tool.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 2
Country: United States

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

That does seem to be the answer.  Thanks!
New Member
Posts: 4
Country: United States

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

 I just bought ACT 2009 (ver 11), new user moving from BCM. and I am having this problem. I do not want to delete a field rather ACT should handle itself by moving a field to new table. This problem is supposedly fixed in 2006 but it is not as I am receiving error.

 

Note: I also posted a log error view for another define fields error which I receive everytime that I add or update a field. Search shbama for listing; perhaps related.

 

Can someone at ACT please reply?

 

Thank you,

David

Moderator
Posts: 4,395
Country: USA

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

[ Edited ]
Are you receiving this error or the error you posted in the other thread.  ACT! 2009 already creates new tables when its reached its max.
Message Edited by dlunceford on 04-27-2009 10:38 AM
Copper Contributor
Posts: 5
Country: United Kingdom

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

I have ACT! by Sage 2008 (10.0) Version 10.0.0.237, Hotfix 1 and encountering the same problem...

 

I have tried actdiag and when I go to select a database, the only on that gives me access is Act! DEMO...

Then, I do not get the notepad at all.... only an Act! window with a series of gobbly **bleep** data that does

not resemble the

Copper Contributor
Posts: 5
Country: United Kingdom

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

sorry cut off...

 

.... doesn not resemble the knowledge base article.

Moderator
Posts: 4,395
Country: USA

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

Sounds like you're accessing a shared database.   You will need to run these steps on the server.
New Member
Posts: 4
Country: Canada

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

I have ACT! by Sage 2009 (11.0) Version 11.1.183.0, Hotfix 1

 

i am trying to increase the size of a field and keep getting the error message. Why isn't act creating a new table for my field? I do not have the option to delete some other field so i can assign space to this one.

 

any ideas?

 

 

CEC
Tuned Listener
Posts: 9
Country: USA

Re: Error "Combined field lengths have exceeded max for database ... Resize or delete ..."

I have ACT! Premium FFP 12, Hotfix 3

 

Could someone explain something to me?  I am trying to increase the size of a field and keep getting the error message. The answer ID 16530 says that the table is locked due to having reached the maximum size of 8000 bytes (a really lame limit to begin with!)  Then it goes on to say that "When a table reaches its maximize (sic) size, a new (spillover) table is created.   Why isn't act creating the new spillover table for my field? I need all of the fields I have created.

I called ACT! support and he walked me thru something which eliminated the error message at one time but now it is back, so I am guessing that this is a programming bug and that there is a workaround.

 

Help would be greatly appreciated!