Community
Showing results for 
Search instead for 
Do you mean 
Reply
Accepted Solution

Error message: Database could not be accessed...check your network connection...

New Member
Posts: 7
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Thanks again!

 

I did that and when it tried to open it said it needed to verify the database - I selected OK. Then it came back with an error message "Database <dbasename> already exists. Choose a different database name."

 

I'm lost not having access to this system... Any other suggestions?

 

Best,

Chris

 

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

We'll try this again, but before attempting it - do the following in ACTDiag.

 

- Start > Run > Actdiag > Enter key

(or Start > Search field > Actdiag > Enter key)

- In Actdiag: Databases menu > Database List

- Find databasename in list > left click on gray box to left of name (to highlight)

- Right click on same box and select 'Detach Database'

 

- Rename PAD file (if present) > open with ADF

Greg Martin
Sage
New Member
Posts: 7
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Greg,

 

I tried that as well and still come up with the same exact error message. 

I think its a programming error with the original database being in XP, while the new setup is in 7. A connection is just not being made. Suggestions on how/whom I can escalate this with?

 

Thanks!!

 

Chris

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Certainly there are several Certified Consultants that participate in the Community, that would be able to assist you with this (for a fee).  You can also call into Sage ACT! Support, again - for a fee.  But let's try one more thing first:

 

Since the error indicates database name in use:

- browse to the database files

- remove the PAD file (if present)

- rename the ADF, ALF, and 'database files' folder by adding the word 'new' to the beginning of the existing name.

 

Example:

If database name is 'Chris.ADF', rename it to 'newChris.ADF'.  Do this for the ADF, ALF, and 'database files' folder.

 

- open ACT!

- open database using ADF

 

If the database opens successfully, it can always be renamed later using the Backup and Restore (Restore As) options.

Greg Martin
Sage
New Member
Posts: 7
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Thought I got pretty close on that one, however, another message came up after I tried that and it verified the database: 

 

User License Count Exceeded. 

There are not enough licenses in this database to allow you to login. Please contact your administrator.

 

I'm done playing with this.. What is the best course of action to quickly and inexpensively get back online? 

 

Thanks for all your help!

 

Chris

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Ok - that message just means there are more active users defined in your database that you have licenses for...

 

Have you registered your installation yet?  Check in ACT! > Help > Register ACT!.  If it is already registered it will tell you how many licenses you have.  Unfortunately you can't tell how many active users are in the db until you get it open.

 

If it isn't registered, register it and then open the database.

Greg Martin
Sage
New Member
Posts: 7
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

its already activated with 1 user

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Assuming you are the only username defined in the database, try running ACT! 'As Admin'.  To do this: close ACT! > right click on ACT! icon > select 'Run as Administrator'.

 

Try opening the demo database > do you get the same error?

 

 

 

The error indicates that there are more than 1 active users defined in the database, or that your username doesn't have Admin authority in the database (first open must be by an Admin username). 

 

If you have other serial numbers for ACT!, enter them into this installation (Help > Register ACT!).  Then attempt to open the database.

 

Do you recall if there were additional users defined to the database?  If yes, it could be that your username does not have Admin authority - if you can remember other usernames, try them.

 

If you are the only user defined in the database, the support team can assist with getting past this message.  They have the capability to change your username to an Admin.  Support can be reached at 800-927-3989, but you will have to purchase a 1-event support plan (or an annual support plan).

Greg Martin
Sage
New Member
Posts: 7
Country: USA

Re: Error message: Database could not be accessed...check your network connection...

Greg,

 

Thanks a lot! 

I am the only person using this program, and the only license that I've purchased. I have two different db's in there (one is older and not used) and then the newer one that I use daily... 

 

I tried to open the demo under admin and basically got the same kind of error messages as before. 

 

I'll be calling in for the single instance support asap.

 

Thanks again,

Chris