Community
Showing results for 
Search instead for 
Do you mean 
Reply

Error: controls created on one thread cannot be parented to a control on a different thread

New Member
Posts: 3
Country: USA

Error: controls created on one thread cannot be parented to a control on a different thread

Using ACT 2011 PRO on laptop running WinXP Pro.

 

Performed database maintenance, check and repair. After program completes maintenance, it finds error(s). After 'fixing' error(s),  error message:  "Controls created on one thread cannot be parented to a control on a different thread."

 

I've tried to fix this error by 1. back up database as suggested, and  2. perform error fix. Programs states unable to fix and consult support.

 

Is this critical? What am I doing wrong or what can I do to fix this?

 

It's very difficult for me to move forward to ACT Premium with additional licenses for more users when I am experiencing these technical difficulties. What to do?

Thanks.

Jack

 

Bronze Super Contributor
Posts: 1,537
Country: United_Kingdom

Re: Error: controls created on one thread cannot be parented to a control on a different thread

I'm also getting this message occasionally and wondered if anyone knows what it means and if there's a solution.

David Shaw
Act! Certified Consultant since 2001
Office:    +44 (0)1483 714507
Mobile: +44 (0)7977 567 318
E-Mail:    dshaw@act4u.org 
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Error: controls created on one thread cannot be parented to a control on a different thread

To help determine if this issue is specific to the database or environmental, perform the following:

1. Test 'Check and Repair' in the demo database.  If same error, there is an environmental issue.

 

2. Attempt the maintenance using the ActDiag utility.  Instructions are within this article: KB Article 26854

Greg Martin
Sage
Copper Super Contributor
Posts: 219
Country: USA

Re: Error: controls created on one thread cannot be parented to a control on a different thread

Sage ACT! 2012, Windows 7, SP1

 

I have also been getting this message fairly frequently, followed by another  - Indes as outside the bounds of an array.  And then sometimes followed by Object Not set to an Instance of an Object.  This has been happening fairly regularly for the past few weeks.  Did Maintenance, reinstalled ACT [not sql] and not fixed.  Any suggestions? 

Cindy Gavelek, M.Ed., ACC
Confluence
cgavelek@confluencecorp.com