Showing results for 
Search instead for 
Do you mean 

Error Unpacking Remote Database

Copper Contributor
Posts: 5
Country: United States

Error Unpacking Remote Database

I'm having the same error that I did from this post: am having trouble unpacking and restoring a RDB on a new Win 7 x64 laptop. I get the error message, "invalid length parameter passed to the substring function".


I thought I knew the fix in case that error happened again, but the workaround of installing the extra features of SQL Server isn't doing the trick this time. I've exhausted all of the tricks I know to do.


Any suggestions?


P.s. Sorry for posting twice, but I wasn't sure if a post with a solution marked would garner any attention.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Error Unpacking Remote Database

Hello carbonell35,
Try this:
- Close ACT!
- Browse to the ACT! program directory - by default this is
C:\Program Files (x86)\ACT\ACT for Windows
- Locate the file "SecurityCmdLnApp.exe"
- Right-click on it and select "Run as Administrator"
- When complete, re-open ACT! and attempt to restore the RDB

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 5
Country: United States

Re: Error Unpacking Remote Database

Thanks for the reply, Greig. Unfortunately, I've tried this with no success. Any additional thoughts?