Community
Showing results for 
Search instead for 
Do you mean 
Reply

Error-The database could not be accessed

Accepted Solution Solved
New Member
Posts: 1
Country: United States
Accepted Solution

Error-The database could not be accessed

I have ACT! 2008 running on a SBS 2003 server and 5 users, 2 on Vista and 3 on XP.  The database is sitting on the server.  All the clients get the same error when trying to access the database on the server... "The database <database name> could not be accessed.  In order to access this database, check your network connection and verify that the database server is available.  It may be necessary to disable any firewall software on your computer or the server.  Press F1 for a troubleshooting guide."

 

I've tried everything in the troubleshooting guide and gone through the FAQ's with no luck.  If i create a new database on a client computer, I can access it from the server with no apparent problems.  But I cannot access the database on the server from any of the clients.  Sounds to me like something on the server is blocking the access but I can't figure out what it is.  Anyone kind enough to share any insight to this problem will be greatly appreciated.

 

p.s.  If this winds up in the wrong place on this board please accept my apologies in advance.


Accepted Solutions
Solution
Accepted by topic author gstarr
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 27
Country: United States

Re: Error-The database could not be accessed

I am having the same problems too with version 10.  I created a database on my computer and then moved it to a network drive and I have two other users that can't access the database off of the network.

View solution in original post


All Replies
Solution
Accepted by topic author gstarr
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 27
Country: United States

Re: Error-The database could not be accessed

I am having the same problems too with version 10.  I created a database on my computer and then moved it to a network drive and I have two other users that can't access the database off of the network.
New Member
Posts: 1
Country: United States

Re: Error-The database could not be accessed

I was plagued with this problem all of last week.  We have 1 computer which houses the SQL server that shares the ACT database over our network.  ACT works fine on that machine, and failed to connect from 2 others on the network.  After doing some testing, I found out the problem was the host computer's firewall was blocking the SQL features.

 

Solution as it worked for me:

 

On all your networked computers running ACT:

 

Start->Run->services.msc and hit enter

 

Scroll down until you find the 2 services that act has started for your SQL server.  Should be something like

 

SQL Server (ACT 7) and

SQL Server Browser

 

Double Click on each of them and make note of the file and path they reference to.  Should tag to sqlservr.exe and sqlbrowswer.exe or something very similar.

 

Start->Control Panel->Windows Firewall

 

Open Exceptions tab (make sure that the Don't allow exceptions box is NOT checked)

 

Now choose Add Program and Browse and add in both of the above programs as exceptions.

 

When this is done, restart the host PC.

 

Appears that the host computer's firewall was creating a conflict with the SQL setup of ACT.  With the added exceptions it cleared up the problem.

New Member
Posts: 1
Country: United States

Re: Error-The database could not be accessed

I see this topic has had many, many posts and threads, which is a bit worriesome since it's now happening to me!   

 

rmaltzen - I tried your instructions (very clear, thank you) to no avail.  One problem I'm running into with your suggestion is that my Windows Firewall shouldn't be causing a block because it is off (because it tends to get in the way of my Norton and vice versa), so that doesn't seem to be the problem.  I have also tried disabling my Norton, but that didn't seem to make a difference either. 

 

I have tried starting SQL Server (ACT 7) and restarting SQL Server Browser.  Didn't seem to make a difference.

 

Any other suggestions? 

 

Thank you!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Error-The database could not be accessed

Here is a good Knowledgebase article that lists the exceptions to add to your Firewalls/Anti-virus software:

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2512...

 

 

Greg Martin
Sage
Avid Listener
Posts: 43
Country: United States

Re: Error-The database could not be accessed

Welcome to an issue Act! has no idea how to fix.  Sorry to burst your bubble.  Support will let you run in circles for weeks but can not fix it.  If they are confident and say they can, make them a deal - let them pay you for your time and see if they take the bet.  My quess is they will not.

 

I spent a full two weeks on this and zero.  Had to put the database on an another machine. 

 

If someone doubts this, I'll give you the case number.

 

You will never get this to work!

 

 

Nickel Elite Contributor
Posts: 934
Country: USA

Re: Error-The database could not be accessed

[ Edited ]

Have you tried this,

Go to each pc and clear/delete your antivirus/firewall application rules.

They will get recreated as you run those apps again.

 

Is Sql ACT7 Server service started?  Close ACT! - Start/Run/Services.msc  then scroll down list and double click SQL SERVER(ACT7)- start it if not started.

 still no luck?

Rite click your ACT! icon and select run as admin?  and insure UAC(User Accts Control is turn off) -access it thru your control panel.

 still no luck?

Important read this very specific kb article re your error msg

Error: "The database <Database name> could not be accessed. In order to access this database, check your network connection and verify that your database server is available. It may be necessary to disable any firewall software..."

Reference kb article http://kb.sagesoftwareonline.com/app/answers/detail/a_id/19640/kw/2008%20Error-The%20database%20coul... 

 

Not sure what string of events lead up this this prob, but there is also option;Close ACT! and Start / Run ACTDIAG 

Cheers - FSB

Bill Williams - Owner/Consultant/Trainer at Fill Staff "ACT! FOR RECRUITERS"
Manage Your ACT! Backups http://fillstaff.com/backupfolderspro.html - FREE
BIG ACT! LAYOUTS for Larger Monitors www.bigactlayouts.com
Protect your Files & Folders with Folder Lock Pro by New Software http://download.cnet.com/Folder-Lock/3000-2092_4-10063343.html
New Member
Posts: 1
Country: USA

Re: Error-The database could not be accessed

KUDOS to rmaltzen! Thank you!!!

 

We upgraded our ACT! server and were faced with the dreaded "The datavbase XXX could not be accessed..." message.

After several fits and starts, including just about every manipulation of file sharing, ownership, etc., of the shared database, I found this post and it fixed the issue.

 

To wit:

 

Start->Run->services.msc and hit enter

 

Scroll down until you find the 2 services that act has started for your SQL server.  Should be something like

 

SQL Server (ACT 7) and

SQL Server Browser

 

Double Click on each of them and make note of the file and path they reference to.  Should tag to sqlservr.exe and sqlbrowswer.exe or something very similar.

 

Start->Control Panel->Windows Firewall

 

Open Exceptions tab (make sure that the Don't allow exceptions box is NOT checked)

 

Now choose Add Program and Browse and add in both of the above programs as exceptions.

 

When this is done, restart the host PC.