Community
Showing results for 
Search instead for 
Do you mean 
Reply

Dialer in ACT 2010

New Member
Posts: 13
Country: USA

Dialer in ACT 2010

I am using the ACT Dialer in Act 2010 (and an external USB Modem since my laptop does not have a phone jack anymore). I am able to dial most phone numbers from ACT, however for some contacts I get "Object reference not set to an instance of an object". After clicking OK 4 times, the dial pop up appears but with "Dial" grayed out. I was not able to determine what the contacts behaving this way have in common.

 

Thanks

Cristian

Bronze Super Contributor
Posts: 1,170
Country: USA

Re: Dialer in ACT 2010

Are you sure that you cannot ascertain some commonality among the records that cause the error?

 

From countries outside of the US?  Certain area code? No Area code?


RJS
Copper Contributor
Posts: 28
Country: USA

Re: Dialer in ACT 2010

Hi,

 

I followed instructions regarding changing my format for phone fields by copying the info in the field to another field then formatting the phone field like I wanted and leaving no numbers in  field. I then copied what I saved back to the correct formatted phone field and it changed my format like I wanted for my entire database. This worked wonderfully.

My problems now is it is giving me the same error as described by the user above- object reference not set to an instance of an object - when I use the dialer.

 

I experimented with another database where I did not copy and reformat the phone fields and it works perfectly. I then copied and changed the phone fields in that database and now I get the same object reference error. I also tried to format the field back to a different format and that did not fix it.

 

It appears once the field is changed using the copy and replace method the dialer never works correctly.

 

I also deleted my software and reinstalled, restored the database with a new name and deleted and recreated my Preference files.

 

If I click past the error message a few times the dialer works correctly but that is too much work and defeats the ease of dialing.

 

Can anybody assist please?

Rob
RobJSinger.com