Community
Showing results for 
Search instead for 
Do you mean 
Reply

Database Supplemental Files - Error

Accepted Solution Solved
New Member
Posts: 1
Country: USA
Accepted Solution

Database Supplemental Files - Error

I need help. I am trying to share our Act by Sage version 2008 (10). I have had nothing but problems. I called tech support to find out I was 31 days past install and they would only support thru payment. So long story short. I have had database sharing problems since we got our 5 users license. I have searched online and have been able to fix all but one of my problems.

 

1st error was "The database could not be accessed. In order to accesss......." I believe I was able to fix this thanks to this site which was a 14 page fix. Way too hard to configure. This program should set all the features that it needs during install.

 

Now to my latest problems. Everything was opeing great then I get this error "Cannot find database supplemental files folder <data name> in this location <sales1>. This could be a problem with the share, or the folder may not exist. Please contact the administrator of your database."  Problem is I am the administrator. I have no supplemental files. So how do I fix this.

 

Any help would appreciated.

Thanks

Matt


Accepted Solutions
Solution
Accepted by topic author mdiehlusa
‎09-25-2015 03:20 AM
Copper Elite Contributor
Posts: 118
Country: india

Re: Database Supplemental Files - Error


All Replies
Solution
Accepted by topic author mdiehlusa
‎09-25-2015 03:20 AM
Copper Elite Contributor
Posts: 118
Country: india

Re: Database Supplemental Files - Error

New Member
Posts: 2
Country: United States

Re: Database Supplemental Files - Error

[ Edited ]

This worked for ACT 2006, when I moved "shared" ACT database from one server to another. 

 

I followed standard procedure for moving the "shared" database (via "Backup" and "Restore as" ) but still had problems.  Remote clients would get the error "Cannot find database supplemental files folder".  The below procedure fixed it.

 

Requires a SQL server of the same version as the ACT server instance (SQL 2000 for ACT 2006)

 

  1. Stop the ACT SQL 2006 instance
  2. (If needed) copy the ACT ADF and ALF files to the server running the needed SQL server.
  3. Open Enterprise Manage manager on the SQL server.
    1. Right-Click on the SQL server "Databases" and select "All Tasks -> Attach Database"
    2. For MFD, select the ACT ADF file
    3. Make sure you set "database owner" to "sa"
    4. Click OK.
  4. Expand the ACT database to "Tables".
  5. Right click on the table "CTL_DBCONFIG" and select "Return all Rows"
  6. Find the line in the SECTION column labeled DATASTORE.
  7. Change the CONFIGVALUE value on that line from the localharddrive ("D:\ACT\......" ) value for the "-database files" to the appropriate UNC location for the supplemental files folder (\\ACT-SERVER\ACT\.... ).
  8. Change to another line to save the changed value.
  9. Close the table and detatch the database.
  10. Copy the modified ADF and ALF files back to the original location.
  11. Restart the ACT SQL server instance.
This resolved the problem.
Message Edited by jchristiansen-onward on 04-10-2009 09:36 PM
New Member
Posts: 2
Country: United States

Re: Database Supplemental Files - Error

Note:  After this, do not re-open ACT from the local server. (Only open it from remote clients.) 

 

Opening it locally sometimes "re-breaks" the ACT supplemental files folder database entry.  (the below procedure fixes it again.)

 

 

John Christiansen

http://www.onwardtek.com

New Member
Posts: 3
Country: United States

Re: Database Supplemental Files - Error

I am running ACT 11 on a Vista (SP2) machine.  Another machine in our office is attached to the ACT database and has worked fine for over a year.  All of a sudden last week, I started getting the "supplemental files folder" error as listed above.  I believe the night before ACT quit working, Window loaded some updates, so I'm suspecting this may be the cause...hmmmm.  I was wondering if anyone can give the steps necessary to unattach and reattach the database to SQL 2005.  Any information would be greatly appreciated.  Thanks!

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Database Supplemental Files - Error

Try this: open your database on the host machine > go to Tools\Database Maintenance > click on 'Share Database' (this will unshare it).  Close Act! > reopen it and go back to Tools\Database Maintenance and click on 'Share Database' (to re-establish the sharing on the folder).  Test.

 

If that does not resolve the issue, visit this link (same as link above): Cannot find database supplemental files folders

Greg Martin
Sage
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Database Supplemental Files - Error

New Member
Posts: 1
Country: USA

Re: Database Supplemental Files - Error

[ Edited ]

Thank you for this!  I just lived through a similar experience. I was migrating from SBS 2003 one one machine to SBS 2008 on a new machine while (and at the same time) converting from ACT 2006 Premium to ACT 2011 Premium. I installed SQL server 2008 but I couldn't attach the database files as you indicated because of a version mismatch so I gave up on that.  I did have the SQL management tools installed though so I was able to simply connect to the running ACT SQL Express instance and modify the table directly. My steps to success ultimately were as follows:

 

 

  1. Install 2011 Premium on new server
  2. On old server, open database and turn off sharing (not sure if this mattered)
  3. Back up database
  4. "Restore as" database onto new server using 2011 into new name
  5. Connect to running ACT7 sql express instance with sql server management tools
  6. Follow jchristiansen-onward's steps 4-8
  7. Close SQL server management
  8. Connect with ACT from a client machine, not the server
  9. Rejoice (or, alternately, weep uncontrollably)
Note: At no time prior to step #8 above was I able to check off the 'Share Database' menu item; it was always greyed out.  This caused me great consternation  but evidently it didn't matter.  Once I opened it from a client machine the menu option was both enabled and checked.


To help people like me who searched fruitlessly for the above-mentioned issue, I offer these keywords:

2011 premium share database greyed grayed out

restore database unable to share