Community
Showing results for 
Search instead for 
Do you mean 
Reply

Database Move/Restore

New Member
Posts: 4
Country: USA

Database Move/Restore

Hello everyone,

 

Can a large amount of attachments cause a database to run slowly?

 

I'm in the process of performing a database move.  Act is building the database right now and it looks like it has been stuck on "Move Database: Attachments" for about 20 minutes now.  The attachments directory is 6GB in size.

 

Any thoughts?

 

Thanks

 

New Member
Posts: 4
Country: USA

Re: Database Move/Restore

I just done the database move and it looks like everything is working as intended on the client side.

 

On the server side, I noticed something I've never seen before....

 

Look at this screenshot.  For some reason every single file in attachments is listed on the Disk monitor..

 

2017-10-27_9-41-25.jpg

 

The CPU is also hitting 99% for a few minutes at a time.  It's a little worrying as the users will soon be coming into the office, I hope this doesn't slow their connection to a halt.

 

Could this have something to do with the database only just being moved to this server?

 

Thanks

 

New Member
Posts: 4
Country: USA

Re: Database Move/Restore

This seemed to clear up by itself.
Administrator
Posts: 298
Country: United_Kingdom

Re: Database Move/Restore

Glad to hear this cleared itself up.

 

After a database is moved, or backed-up then restored, the database will re-index the files and attachments - this can absolutely cause things to run slowly until the re-index is complete.

 

The larger the database, the longer this process can take.