Community
Showing results for 
Search instead for 
Do you mean 
Reply

Creating new database

New Member
Posts: 11
Country: USA

Creating new database

I hope anyone can help with this problem. When I try to create a new database I get this error message below. If you can help I would really appreciate it. Thanks Sam

 

Unable to create the database. There is an error connecting to

the Microsoft SQL Server.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Creating new database

Hello Sam,
This error may indicate the SQL service is not running:
- Close ACT!
-Click your Windows Start button
- Click Run (Windows XP) or go to the Search box (Vista, Windows 7)
- Type "services.msc". This will open the Services window
- Locate the service "SQL Server (ACT7)"
- Right click on this service and select either "Start" or "Restart", whichever is not grayed out
- Close the services windows, reopen ACT! and test

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Creating new database

Thanks Greig I tried what you said and I get this error message when I

right click and start the SQL Server (ACT7)

If you have more information I would certainly appreciate it. Thanks again Sam

 

Windows could not start the SQL Server (Act) on local

Computer. For more information, review the System Event Log. If

This is a non-Microsoft service, contact the service vendor, and

Refer to service-specific error code 3417.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Creating new database

This may be a problem with the login account that the service is using. Try this:

- From the start button, type services.msc to open the services window

- Right-click on the SQL Server (ACT7) service and select Properties

- In the Properties screen, click the Log On tab

- Click the option for This account and type in either your Windows username and password or that of an administrator

- Click Apply...you will be prompted to restart the service

- Click OK, then click on the General tab, and click Start

 

If this does not resolve, then you may need to uninstall and reinstall the SQL Server. I can provide additional instructions if this is the case.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Creating new database

Hi Greig and thanks again. I did try what you said and I still get that error message. Yes I would like to try what you have suggested. Thanks Sam

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Creating new database

OK. A few questions:
- What operating system is your machine using?
- What version of ACT! are you using?
- Are you logged into your machine as a Windows administrator?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Creating new database

My operating system is Vista home, I am using Act 2010 just one user but I had them synced. Don't know how to login as an administrator. Thanks Sam

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Creating new database

[ Edited ]

Before trying the uninstall/reinstall, let's first try disabling the User Account Control (UAC) function in Vista.

- Go back into the Services list, right-click on the SQL Server (ACT7) service, choose Properties, then under the Log On tab change the log in back to Local System

- Follow the steps in KB Article 20220 to turn off UAC, reboot your machine, then attempt to start the SQL Service again

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 11
Country: USA

Re: Creating new database

Hi Greig I have tried all of your proposals except using the registry editor. I don't want to mess with this I am a little good with computers but that is out of my range. If there is any other way I would be delighted to here. Thanks Sam