Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot sync over network "unable to connect to sync server"

Accepted Solution Solved
Copper Contributor
Posts: 13
Country: United States
Accepted Solution

Cannot sync over network "unable to connect to sync server"

I am running the host database on a Windows Vista laptop, the remote database that I want to accept a sync back from is on a Windows XP laptop.  Same version, same build.  The computers can ping each other.  I have disabled firewalls.  When I run netstat on the host computer, I do not see port 65100 listening.  In act, it says that the sync server is running.   Any ideas what to try next?  I am stumped and am at a work stoppage until I can get these databases to talk to each other.

 

Thank you.


Accepted Solutions
Solution
Accepted by topic author vthokie88
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Cannot sync over network "unable to connect to sync server"

Hello,

In your original post you mentioned you had disabled all firewalls. If you disabled the Windows Firewall on the Vista machine, this will actually block all incoming traffic (this is a Vista characteristic). You will need to re-enable the Windows Firewall on the Vista machine (the host) and add the following exceptions (if not already added):

 

Programs

C:\Program Files\ACT\Act for Windows\actsage.exe

C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe

 

Ports

TCP Port 1433

UDP Port 1434

TCP Sync port (65100 by default)

Dynamic SQL TCP Port (instructions to find below)

 - From the Start menu, type actdiag in the Search box

 - When ACT! Diagnostics opens, click Server, then Server Security

 - The dynamically assigned TCP/IP port will listed in the bottom half of this screen

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Copper Contributor
Posts: 13
Country: United States

Re: Cannot sync over network "unable to connect to sync server"

Okay, I now see the port as listening when I netstat on the host machine, but still cannot sync. 

 

TCP  0.0.0.0:65100  PRIME5:0   LISTENING

 

Still looking for ideas on what to look at next.

Copper Contributor
Posts: 13
Country: United States

Re: Cannot sync over network "unable to connect to sync server"

I cannot telnet from the subscriber computer to the host computer.  It says it could not open connection to the host.  I have tried changing the port - no change in outcome.
Solution
Accepted by topic author vthokie88
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Cannot sync over network "unable to connect to sync server"

Hello,

In your original post you mentioned you had disabled all firewalls. If you disabled the Windows Firewall on the Vista machine, this will actually block all incoming traffic (this is a Vista characteristic). You will need to re-enable the Windows Firewall on the Vista machine (the host) and add the following exceptions (if not already added):

 

Programs

C:\Program Files\ACT\Act for Windows\actsage.exe

C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe

 

Ports

TCP Port 1433

UDP Port 1434

TCP Sync port (65100 by default)

Dynamic SQL TCP Port (instructions to find below)

 - From the Start menu, type actdiag in the Search box

 - When ACT! Diagnostics opens, click Server, then Server Security

 - The dynamically assigned TCP/IP port will listed in the bottom half of this screen

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 13
Country: United States

Re: Cannot sync over network "unable to connect to sync server"

Greig,

 

Thank you so much.  That fixed it.  Now all I need to do is find the solution to having a user not on the network and syncing with her and all will be fine.  If you have any ideas on that, let me know.

 

Thanks,

Jeanne

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Cannot sync over network "unable to connect to sync server"

If you are using ACT! by Sage, this is an option:

 

How To Setup Hamachi® VPN For Remote Synchronization With ACT! by Sage and ACT! by Sage Premium 2005...

 

 

If you are using ACT! by Sage Premium, then you can install the Internet Sync Service:

 

How To Install And Configure Internet Sync Service For ACT! By Sage Premium 2009 (11.0)

 

 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.