Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot open shared database - port 1434

Accepted Solution Solved
Copper Contributor
Posts: 20
Country: USA
Accepted Solution

Cannot open shared database - port 1434

I have Act 2013 installed on a server.  Its pointed to a database locally.  I shared the database.  I installed Act 2013 on a workstation and am now trying to connect to the database on the server.  I get an error that the server couldn't be reached because the port 1434 may be blocked. 

 

There is no firewall between the workstation and the server.  The firewall on the server is turned off.  There is no antivirus on the server yet.  The workstation has symantec endpoint protection installed, but there are no firewall settings set to block that port.  I have added the application exceptions just to see if that would make a difference, but it didn't.  The server is set to listen on 1434.  Just for grins, I enabled "synchronize database" and "accept incoming syncs" for port 65100 on the server, but that didn't make a difference either.  What else am I missing?  Any assistance would be appreciated.


Accepted Solutions
Solution
Accepted by topic author tcrogers
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 20
Country: USA

Re: Cannot open shared database - port 1434

I restarted all the SQL services and it started working.  I had to setup the SQL instance separately from the install because SQL wouldn't install during the act install process.  I went in and enabled the protocols for the ACT7 TCP/IP and named pipes.  I rebooted the server.  I followed the instructions in the knowledgebase on how to do the SQL instance manually, so I assumed that was all I needed to do.  But, I had to restart the SQL server services in addition.  The instructions didn't say that the protocols for SQLEXPRESS needed to be enabled as well.  I had restarted the ACT7 instance, but I went back and restarted both the ACT7 and SQLEXPRESS and that fixed it.  I can connect now.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Cannot open shared database - port 1434

Copper Contributor
Posts: 20
Country: USA

Re: Cannot open shared database - port 1434

[ Edited ]

Negative...could not open connection on port 1434.  Isn't telnet tcp?  We're talking UDP here, right?  I tried to telnet 1433, but it didn't work either.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Cannot open shared database - port 1434

Copper Contributor
Posts: 20
Country: USA

Re: Cannot open shared database - port 1434

No firewall between server and workstation.  There is a firewall on the local workstation (running win 7).  I uninstalled Symantec to test it, but that wasn't it either. 

Solution
Accepted by topic author tcrogers
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 20
Country: USA

Re: Cannot open shared database - port 1434

I restarted all the SQL services and it started working.  I had to setup the SQL instance separately from the install because SQL wouldn't install during the act install process.  I went in and enabled the protocols for the ACT7 TCP/IP and named pipes.  I rebooted the server.  I followed the instructions in the knowledgebase on how to do the SQL instance manually, so I assumed that was all I needed to do.  But, I had to restart the SQL server services in addition.  The instructions didn't say that the protocols for SQLEXPRESS needed to be enabled as well.  I had restarted the ACT7 instance, but I went back and restarted both the ACT7 and SQLEXPRESS and that fixed it.  I can connect now.

New Member
Posts: 3
Country: USA

Re: Cannot open shared database - port 1434

Hi Everyone,

 

I am experiencing the same problem on our ACT 2013 but I am not technical as tcrogers.  Would you mind "translating" your solution so that I can follow it step by step?

 

Thanks for your help!

New Member
Posts: 3
Country: USA

Re: Cannot open shared database - port 1434

By the way, we don't have an "actual" server.  We access our database via cloud.

Copper Super Contributor
Posts: 218
Country: USA

Re: Cannot open shared database - port 1434

Here's a quick fix that just worked for me....change the pad file so that it points to the internal IP address rather than the host server name.

Ron Madara, ACC, APT

BrainSell Technologies.
(201) 853-9317
New Member
Posts: 3
Country: USA

Re: Cannot open shared database - port 1434

Thanks much Ron!