Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot open shared ACT from workstations

New Member
Posts: 2
Country: Canada

Cannot open shared ACT from workstations

[ Edited ]

We have an ACT 9 database which has been running in shared mode for at least a couple of years. Recently it stopped working (for the past month or so it has been a regular thing to have to kickstart it most mornings by rebooting or detaching db and reattaching but now that is not working). It opens on the computer that is hosting the database but not on any of the clients (all are XP Pro). When trying to access from client we get:

 

Error: "The database <Database name> could not be accessed. In order to access this database, check ...

 

I have scoured the forums here and others too and I have tried everything I can think of. I have tried everything in this thread:

 

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1964...

 

I have turned off all firewalls (Windows, bit defender and router) and also tried leaving them on with appropriate programs and ports added as exceptions. I tried moving the entire database to a different machine and shared it from there but have the exact same problem.Networking shares are good... I can connect and make changes to the folder where the ACT DB resides. I cannot think of anything I haven't tried.

 

I have not reinstalled ACT but that did not make sense since I have the same issue on a different machine. I'm thoroughly stumped and frustrated and not loving ACT right now. Any further suggestions would be appreciated!

 

Thanks in advance.

Message Edited by dlunceford on 11-19-2009 08:57 AM
Bronze Super Contributor
Posts: 1,170
Country: USA

Re: Cannot open shared ACT from workstations

Have you tried sharing the demo database from the 'server' machine?  If this works OK, then that at least helps narrow down that your issue is specific to your database....  (which it kind of sounds like it might be since you say that you see same thing when database is hosted on another PC).
Copper Elite Contributor
Posts: 118
Country: United_Kingdom

Re: Cannot open shared ACT from workstations

The KBA you referenced is pretty comprehensive but...could it be that the client machines are not authenticating as users on the "server" (whichever machine is hosting the database)? From the client machine, are you able to browse to the folder containing the database (via Windows Explorer) without being prompted for authentication? If the ACT! "server" is just a PC and not on the same domain as the client machines, this could be a possible cause.

 

ACT! 2010 UK Experts

 


Will Ingleby
ACT! Certified Product Specialist

Solutions for Accounting & CRM (UK)

New Member
Posts: 2
Country: Canada

Re: Cannot open shared ACT from workstations

I'll give sharing the demo database a try to see if that narrows it down.I'll repost either way to let you know what happened.

 

I am able to go to folders via Windows Explorer and make changes to files without being prompted for credentials.

 

Thanks for the responses.