Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot find database supplemental files...

Bronze Contributor
Posts: 930
Country: USA

Cannot find database supplemental files...

Got a client with ~6 users on ACT! Premium 2009 Premium + 1 user over a Sonicwall VPN (nobody syncs).  DB is hosted on XP Pro box.  Up until recently all was fine until IT guy took one previously working desktop back to shop to re-image.  Upon return, it started getting the above referenced error.  I've tried all fixes in KB 14101 even though it's supposedly only relevant to ACT! 2005 & 2006.  What finally got him working was when i used ACTDIAG to change the databstore location to the name of the server 'server' and then it worked.  But now the VPN client gets the Supplemental File error.  When I change the datastore location back to the IP, the VPN user now works, but the next time the re-imaged dekstop tries to open, he gets the supplemental file error - in other words, it flip-flops back and forth between machines depending on how I set the datastore location.  And when I change the datastore location, it's okay until they close and open ACT! again.

 

Signature
Bronze Contributor
Posts: 930
Country: USA

Re: Cannot find database supplemental files...

btw, I've always followed every suggestion in KB 19876.

Signature
Bronze Super Contributor
Posts: 1,679
Country: Australia

Re: Cannot find database supplemental files...

Hi Kevin,

 you've already done what I'd recommend (KB 14101 & KB 19876).

 

Jumping the gun I'd be look at NetBios/DHCP/DNS type issues.

 

Do I understand correctly:

SERVER = the machine hosting the publisher database

REIMAGED = the machine in question, it's been wiped and had a new OS image restored to it.

 

REIMAGED - connects on the local LAN ok if using the hostname of the machine hosting the publisher database, that being 'SERVER'

REIMAGED - when connecting over the VPN from out of the office, will connect ok if using the IP address of the machine hosting the publisher database, being something like '192.168.1.2'

 

Have I understood that correctly?

If that is the case, I'd be looking at the DNS settings that REIMAGED uses when using the VPN. It may not 'know' the ip address of the hostname 'server'. One way to fix this might be to add an entry to the HOSTS file (C:\WINDOWS\SYSTEM 32\DRIVERS\ETC\)

 

Ben.

 

 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Cannot find database supplemental files...

[ Edited ]

It looks like the VPN isn't passing the NetBIOS name via WINS (a common issue with VPN) - Note to Ben... WINS rather than DNS unless using FQDNs

When you change the datastore location to IP, did you also check it's the IP in the PAD file?

Bronze Contributor
Posts: 930
Country: USA

Re: Cannot find database supplemental files...

Thanks both for the suggestions - I'm going onsite shortly and have printed your suggestions - I may be getting sloppy on the .pad vs. the datastore location - may be changing one without regard to the other.

Signature
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Cannot find database supplemental files...

The VPN needing IP in the PAD file (doesn't usually need the datastore changed) is common for simple VPNs, especially without a properly configured WINs server

The PAD file change is just a guess as I can't see why the local machine would have an issue with IP .... unless the PAD has machine and then it has some issue with the conflict.

You might also check (by a ping to server machine_name) that it resolves same for local and VPN
Bronze Super Contributor
Posts: 1,679
Country: Australia

Re: Cannot find database supplemental files...

Mike, thanks for the correction Smiley Happy

 

I blame not enough coffee.

 

Kevin, how has it gone?

 

Ben.