Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot apply hot fixes to new v21 upgrade

Astute Commentator
Posts: 38
Country: USA

Cannot apply hot fixes to new v21 upgrade

 

I upgraded my server installation from Premium 2013 to ACT Pro v21 today. I was able to upgrade and open the database, submit the licensing, etc. I am not able to apply any of the Hot Fixes though. When I try to install Update 4, the error message I receive is:

 

"This update does not apply to this version of ACT. Please verify you have the correct update".

 

I am running ACT Pro 21.0.295.0, and I am most certainly trying to install the updates for Act Pro v21. (Screenshot attached). I have tried to "Run as Administrator", and I have tried to install the other 3 as well without any luck. Same error message. The server is running Windows Server 2008 R2 SP1. This server did have ACT Premium 2013 installed on it beforehand, but I uninstalled that version completely before installing v21. My database seems to work fine. I just can't apply the updates. Please help.

Astute Commentator
Posts: 38
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

When I look at the database version from ActDiag, it says 21.0.15.0.

Astute Commentator
Posts: 38
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

Here is a copy of my Hotfix log:

 

 

This is the Act! HotFix.

Applied 12/21/2018 7:58:28 AM

Minimum Act! Version for this HotFix: 21.0.295.0
Version of this HotFix: 21.0.295.4
Products this HotFix is compatible with: ACT2100PremiumACT2100StandardACT2100PremiumWeb
Entering Version Validation
ValidatingVersion...
LastAppliedUpdateVersion: 21.0.295.5
Act! version is: 21.0.295.5
Not version 21.0.295.0
Version Validated: False
Entering Product Validation
Validating Product...
Act! product is act2100standard
Product Validated: True
Checking Product Type: act2100standard
HOTFIX ABORTED *********

HotFix completed
*********************

 

It thinks I have version 21.0.295.5 for some reason. But I downloaded the ACT Pro installation file before update 4 was even released. November 8th I believe, so update 2 wasn't even out yet.

Nickel Elite Contributor
Posts: 987
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

[ Edited ]

Have you tried to MANUALLY check for and APPLY your Windows updates?, then try to apply any needed hotfixes?  Are you Manually downloading the v21 hotfix #5 .  Going from ACT! premium to Pro is not really upgrading but I get it.  Maybe part of the issue is that you are going from Premium to Pro ? ..

When I went to act!21 pro, I also uninstalled act AND sql server stuff and let act install install the sql 2014... 

I also backed up all of my databases using ACT! / File / Backup / Backup databases process prior ..

I also just now noticed there is a hotfix 5.. I will try to install it.

UPDATE5 UPDATE

i JUST INSTALLED ACTV21PRO UPDATE-5 successfully except for a norton firewall alert..

Note: I updated from actv17pro to actv21pro..

ACTv21Pro update5  Version info 12212018.png

Hope this helps.. good luck..

Bill Williams - Owner / ACT! Consultant / Trainer at FILL STAFF HR "ACT! FOR RECRUITERS"
Manage Your ACT! Backups http://www.fillstaffhr.com/backupfolderspro.html - FREE
Backup your ACT! Databases DAILY using ACT! / File/ Backup/ Backup Database.(Include Attachments).
Also - FREE - BIG ACT! LAYOUTS for Larger Monitors http://www.fillstaffhr.com/bigaldl01.html
Also - FREE - BullZip PDF Printer - Print directly to PDF http://www.bullzip.com/products/pdf/info.php
Astute Commentator
Posts: 38
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

Thanks for your reply. All of the updates that I was trying to do were manual installations of the Hot Fixes which I downloaded off Swiftpage's website. Does ACT download updates automatically? I never saw that with ny older version, so I thought I had to manually apply the hot fixes. Like your screenshot, mine also said 21.0.295.0 update 5. The reason this concerned me is because it was a clean install of an installation package I downloaded 6 weeks ago. Long before a majority of the hot fixes were available. Needless to say, I downloaded Hot Fix 5 like you did, and that one seemed to install just fine! I'm relieved because the whole reason we upgraded was because of this licensing issue that expires in less than two weeks, and I wasn't able to install the crucial update 4. So this is good. After applying the hot fix though, my "About" still says 21.0.295.0 update 5. So I don't know if anything really changed. But glad it appeared to have installed. Maybe there is some updating in the background that I wasn't aware of. Thanks for the comments.

Nickel Elite Contributor
Posts: 987
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

You are welcome - sounds like you maybe ok? Let's see what happens when the next update / hotfix / service pack is released.

Bill Williams - Owner / ACT! Consultant / Trainer at FILL STAFF HR "ACT! FOR RECRUITERS"
Manage Your ACT! Backups http://www.fillstaffhr.com/backupfolderspro.html - FREE
Backup your ACT! Databases DAILY using ACT! / File/ Backup/ Backup Database.(Include Attachments).
Also - FREE - BIG ACT! LAYOUTS for Larger Monitors http://www.fillstaffhr.com/bigaldl01.html
Also - FREE - BullZip PDF Printer - Print directly to PDF http://www.bullzip.com/products/pdf/info.php
New Member
Posts: 14
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

I am having the same problem. I have tried for since the middle of December to get any of the updates to work. I can download the file, click on them and the extracting message comes up but once the extracting runs nothing happens. I always run the program as Administrator. I have closed the program and then manually ran it as Adminstrator but the same thing happens.

Astute Commentator
Posts: 38
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

When you view the "About", what version does it say you are running?

New Member
Posts: 14
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

21.0.295.0

Astute Commentator
Posts: 38
Country: USA

Re: Cannot apply hot fixes to new v21 upgrade

What Update number?