Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot access shared database - I've tried everything!

Accepted Solution Solved
Copper Contributor
Posts: 6
Country: USA
Accepted Solution

Cannot access shared database - I've tried everything!

I have ACT Pro 2011  on two computers running Windows 7 64 bit.  I had no problems sharing the database until I changed the network setting for both computers from home network to work network and also reset the router.  There was nothing else on the computers that I changed.   I can share every other kind of document between the two computers, but I can no longer access the shared database pad file.   

 

I get the following error:  "The database [  ] could not be accessed.  In order to access this database, check your network connection and verify that your database server is available...."

 

I have gone through every single knowledge base suggestion I can find, as well as suggestions from posts in the ACT Community board.  I've disabled firewall using services component, rebuilt the database, disabled anti-virus, restarted SQL server, and everything else suggested.  I also changed back to home network from work network and have made sure it is set for no passwords, network discovery, and file sharing. 

 

There was one time I was able to access the shared database, and it was after I rebooted the router again, so I thought my problem was solved, but then after I closed ACT and opened it again, I got this same error message.   So, I know my router settings are okay because I have managed to access the database that one time. 

 

Since I've done everything else, the only thing I can think of is that it has something to do my the TCP/IP settings.  I am otherwise clueless.  I even uninstalled and reinstalled ACT on the second computer and ordered a new router (which has not arrived yet).

 

Please help because I have exhausted all options.  Thanks.


Accepted Solutions
Solution
Accepted by topic author jamesdance
‎09-25-2015 03:20 AM
New Member
Posts: 3
Country: Canada

Re: Cannot access shared database - I've tried everything!

Ok I got mine working. Edit the PAD file in notepad and change the host to the IP address that belongs to the computer hosting the file. Ensure to ONLY put the IP address in.... do not include the \\ .

 

Good luck

View solution in original post


All Replies
New Member
Posts: 1
Country: USA

Re: Cannot access shared database - I've tried everything!

Sorry for asking if you've already tried this.. but at the host machine, you've gone to Tools > Database Maintenance > and selected Share Database?

Chris

Copper Contributor
Posts: 28
Country: United States

Re: Cannot access shared database - I've tried everything!

Hi

Had the same problem - go into windows firewall .Allow programs .. Make sure Home/Work and or public are selected..

Copper Contributor
Posts: 6
Country: USA

Re: Cannot access shared database - I've tried everything!

Yes, the database is checked to be shared.
Copper Contributor
Posts: 6
Country: USA

Re: Cannot access shared database - I've tried everything!

Thanks for the suggestion, but I had completely disabled the firewall so I don't think that's the problem.  However, following your suggestion, I enabled the firewall and checked the boxes to allow ACT for Home/Work and Public, but I still cannot access the shared database.

Copper Contributor
Posts: 28
Country: United States

Re: Cannot access shared database - I've tried everything!

You have probably already tried this. On the act tool bar make sure the database is shared. On W7 map the drive to the database location. Make sure each computer you are sharing can see the database files on the machine you are using as a server.  

Copper Contributor
Posts: 6
Country: USA

Re: Cannot access shared database - I've tried everything!

Yes, it is shared and mapped and I can see the database on the second computer, I just cannot open it.   It is in the default location under My Documents, and then mapped to a drive.  Having it in that location has always worked for me.

New Member
Posts: 3
Country: Canada

Re: Cannot access shared database - I've tried everything!

I am in the same boat as you on this one. Used to have no problems but after installing a new router I receive the exact same message. I have spent over 4 hours trying everything to get it to work again but can only access the database on the local machine. Any more ideas???

Solution
Accepted by topic author jamesdance
‎09-25-2015 03:20 AM
New Member
Posts: 3
Country: Canada

Re: Cannot access shared database - I've tried everything!

Ok I got mine working. Edit the PAD file in notepad and change the host to the IP address that belongs to the computer hosting the file. Ensure to ONLY put the IP address in.... do not include the \\ .

 

Good luck

Copper Contributor
Posts: 6
Country: USA

Re: Cannot access shared database - I've tried everything!

Johnnyd99, thank you so much!!!!  You are a real lifesaver!   There is a solution in the knowledge base to change the name of the computer in the .pad file, but I had checked the pad file and it appeared correct since I didn't change the computer's name.  It would be helpful if ACT would update the knowledge base to include your fix of putting in the host's IP address.  You saved me many more hours of frustration.  Thank you, thank you!!!