Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot access Database

Accepted Solution Solved
New Member
Posts: 12
Country: United States
Accepted Solution

Cannot access Database

Hi.

 

I'm unable to access my data base.  I did the actdiag you suggested.  The data base was under 'Recover".   I tried to repair.. but it said they coulldn't locate the file. 

 

I think I screwed things up because earlier I attempted to clean my computer by trying to delete C:\windows\temp files, any file over one day old and also C:\ *.tmp over one day old.  Some folders were locked, but I can't say that some files were not deleted.  I attempted to restore the files out of the recycle bin but couldn't find any there.

 

Another situation is that I CAN  find *.ADF and *.pad files using windows explorer but cannot locate them in the same folder when using Act! file open browser.  How can that be?

 

I'm not sure what to do... Would doing a restore from Carbonite correct everything?  maybe to a different folder?  Very frustrating.  Thanks.

 

roger


Accepted Solutions
Solution
Accepted by topic author Stealth007
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot access Database

Glad to hear you are able to access the database!

 

Since you are now able to open the database, you can delete the old files.  I recommend performing a backup of the database before doing any more maintenance (it will make it much easier should something go awry).

 

To move the database:

- close ACT!

- open Actdiag and 'DETACH' the database (Delete will not be an option since it is not in Recover status)

- once detached > copy files from the new folder (on desktop) to the default location

- delete the PAD files in both locations

- launch ACT! > get message that previous database cannot be located

- browse through ACT! to the new-new location and open with the ADF.

 

Another option is to make a backup of the database and then restore it using the File > Restore > Database > Restore As option.  You can then give the database a new name and put it in the desired location.  Once the newly restored version has been opened and verified, you can open the original db (on desktop) and use the Tools > Database Maintenance > Delete Database option.  It will only delete the currently opened database.  Once deleted you will open the newly restored version of the database.

 

 

 

Greg Martin
Sage

View solution in original post


All Replies
Silver Contributor
Posts: 1,813
Country: USA

Re: Cannot access Database

YOu need to look for a .alf and a .adf file. Carbonite probably won't work since it doesn't backup files that are kept open by sql like the aCT database files are.  Did you create any ACT backups (using the act scheuler?).

 

Deleting the .tmp files shouldn't have done anything.

 

dont' empty your recycle bin. but see if you can find those alf and .adf files there?

 

 

I'm not extremely hopeful for you.

Test Drive Act! and Quickbooks over Citrix http://GoTryAct.com

Jon Klubnik| ActTrainer.com
(866)710 4228

ACT! Certified Consultant / ACT! Premier Trainer / ACT! Hosting Provider

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot access Database

When you locate the ADF and PAD files, is the ALF and 'databasename-database files' folder also in that location?

 

If all of those files/folder are present:

- copy them to a 'safe' location (make a folder on the c: drive such as 'C:\Act Database')

- delete the PAD file from both the original and new locations (it will be recreated later)

- open Actdiag

- delete the database in Recover status

- open Act! > it should give a message that last database could not be opened

- in Act! > File > Open Database > browse to the new/safe location

- on Browse screen > change 'Files of Type' on the browse screen to 'ADF' (this is the field that will display a selected file - near the bottom)

- select the ADF to open the database (it will automatically recreate the PAD at this point)

 

Note: if the copying of the files to the new location states that the files are in use, you will need to stop the 'SQL Server (ACT7)' process before copying and then restart it after the copy.  To do this:

- click on Windows Start button

- select RUN if using XP, use the Search field if using Vista/Windows 7

- enter command 'Services.msc' and hit enter

- on the Services screen locate the service 'SQL Server (ACT7)' > right click on it and select Stop.

- to Start the service (after copying files) > right click on it and select Start.

 

 

 

Greg Martin
Sage
New Member
Posts: 12
Country: United States

Re: Cannot access Database

Greg... you've made me a very happy man!  Everything worked as you instructed.

 

As a matter of housekeeping can I delete the old folder in the default location?

 

And, can (how) I move the folder from my desktop to the default location?

 

Much thanks!!!

 

Roger

 

 

Solution
Accepted by topic author Stealth007
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot access Database

Glad to hear you are able to access the database!

 

Since you are now able to open the database, you can delete the old files.  I recommend performing a backup of the database before doing any more maintenance (it will make it much easier should something go awry).

 

To move the database:

- close ACT!

- open Actdiag and 'DETACH' the database (Delete will not be an option since it is not in Recover status)

- once detached > copy files from the new folder (on desktop) to the default location

- delete the PAD files in both locations

- launch ACT! > get message that previous database cannot be located

- browse through ACT! to the new-new location and open with the ADF.

 

Another option is to make a backup of the database and then restore it using the File > Restore > Database > Restore As option.  You can then give the database a new name and put it in the desired location.  Once the newly restored version has been opened and verified, you can open the original db (on desktop) and use the Tools > Database Maintenance > Delete Database option.  It will only delete the currently opened database.  Once deleted you will open the newly restored version of the database.

 

 

 

Greg Martin
Sage
New Member
Posts: 12
Country: United States

Re: Cannot access Database

Thanks, Greg. You'd da man!!!
New Member
Posts: 1
Country: USA

Re: Cannot access Database

Greg,

 

I have been haveing the same problems and went through the proceedures as you suggested. When i try to open the new safe database using the ADF files I am greeted with "you don't have permission to open this file" "Contact the file owner or administrator to obtain permission" Considering I am the file owner and administrator I don't know how to get past this? HELP PLEASE!!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot access Database

Hello 4Bluesfans,

Welcome to the ACT! Online Community!

 

From the message, I believe you are running a computer with either Vista or Windows 7.  To resolve this issue you will need to run ACT! 'As Administrator'.  To do this: close ACT! > right click on the ACT! icon > select 'Run As Administrator' > open database using the ADF.

Greg Martin
Sage