Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot Edit Phone Number Format

New Member
Posts: 4
Country: United States

Cannot Edit Phone Number Format

In previous ACT! (from 2003), I was able to enter phone numbers as xxx-xxx-xxxx.  For other formats, there was a box you could select at the end of the phone number field in order to select other country formats, etc.  When my database was transferred to new ACT! 2010 (Ver. 12.1.181.0, Hot Fix 1), the format remained xxx-xxx-xxxx.  However, when I enter new phone numbers, they default to (xxx) xxx-xxxx.  My preferemce is xxx-xxx-xxxx.  But there is no longer any place to change this format. 

 

The online help document states:

You find that you can change the format on individual records by clicking the button at each phone field, clicking Edit Formats, and then clicking OK with the correct default format enabled. When you click OK to the 'Enter Phone Number' dialog box, the Phone field display changes to the correct format

 

However in the detailed contact view, there is no button anywhere near the phone number field where the field can be edited (unlike my previous version of ACT!).  I don't know if this is a problem with all ACT! 2010, or just my installation.  Is there any where else this phone number format can be edited?  Under Tools and Preferences, I do not see any option to edit the phone number format.  Any help is appreciated.  Thanks

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot Edit Phone Number Format

Try recreating your Act! Preference files.  For instructions, visit this link: Rebuild Preferences/Min-Calendars

 

If you are using the Act! email program as your composing program, be sure to pay attention to the first steps in the article (if you are integrated with Outlook this is not a concern).  I recommend skipping the Actdiag steps and go directly to the 'Manually Delete Act! Preferences' section.

Greg Martin
Sage
New Member
Posts: 2
Country: USA

Re: Cannot Edit Phone Number Format

I had the same problem, the aforementioned "preferences wipe" didn't solve the issue and I was more or less scared to the other, more manual method.  Then I ran into this: http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1381...

 

and saw that one can effectively get to the # format dialogue by hitting F2 when you are in a number field.

New Member
Posts: 2
Country: USA

Re: Cannot Edit Phone Number Format

and if you really want to fix it, I bet (like me) you had your windows hardware acceleration ON.  If you turn it off, I suspect these buttons will come back.  It worked for me.  Here's a good site on how to turn this stuff off per operating system: http://www.pixelmetrics.com/Tips/VidBlank/GlobalAcceleration.php.

 

Thank you to keen eyes of my support guy at DataLogic CRM, Inc. (they host my act database in da cloud).

New Member
Posts: 9
Country: USA

Re: Cannot Edit Phone Number Format

The F2 buttion was a great solution. I found when I upgraded my system from XP to Win 7, I lost the format function. The solution was to change the display from Medium 125% back to Small 100%. But, the screen format was too small. F2 does the trick. Thank you.

New Member
Posts: 4
Country: United States

Re: Cannot Edit Phone Number Format

Thanks Craig:

That was exactly the problem.  My version of ACT! (2010 Hot Fix 1) only supports screen resolution of 100%, not 125% (...pretty lame program!).  Luckily, I found an ACT! customer support rep who was willing to help me (I don't have a support subscription) and he figured out the problem pretty quickly.  Any idea if newer versions of ACT! have addressed this deficiency? 

New Member
Posts: 9
Country: USA

Re: Cannot Edit Phone Number Format

I don't know for sure. I'm using 2011 and I was about to purchase 2013 to see if it helped, but the F2 key was a satisfactory solution for me. Lot's of luck.

Craig