Community
Showing results for 
Search instead for 
Do you mean 
Reply

Can't open ACT DB on new PC

New Member
Posts: 2
Country: USA

Can't open ACT DB on new PC

Hi I'm using a new laptop, purchased in Mexico. I'm assuming the operating system is in Spanish. Would this difference in language create an issue?

 

The message I'm getting is: "The (computer) and (database) were found but you do not have the appropriate share permissions to access the (folder) in the (computer). You may need to enable "file and print sharing" in the firewall of the (computer). Checking your Windows file share permissions may resolve this issue".

 

The database owner and I have done the following:

activated share permissions

closed down the firewalls

named and remaned the pad and rdb files

 

Nothing has helped. I have the theory that it might be a language issue. Act Pro is trying to run some system or file which is named in English and it's not finding it on my laptop just because the names don't match because my laptop's operating system is in Spanish. If this is the case, how can we resolve it? If the programming language and file names are not the issues, what else can we do to fix the fact that I can't open the database on my new laptop?

Nickel Contributor
Posts: 193
Country: Germany

Re: Can't open ACT DB on new PC

[ Edited ]

It is most probably NOT a language issue.

The problem is eventually caused by a missing DLL of a special version.
It seems to happen only with v19 versions and is a rare one...

Download the attached dll in to a folder created for this purpose:
c:\test\

Open a command line "as Admin" into the ACT! installation path on your HD.

run following commands:

gacutil /l office
(Shows a list of registered dlls.)

gacutil /i c:\test\office.dll
(registers the missing dll.)

gactutil /l office
(Shows a list of registered dlls, now including the new one.)

Try to open the local database again.

 

Andreas Schlesselmann
Melville-Schellmann GbR
Germany
www.melville-schellmann.de
New Member
Posts: 2
Country: USA

Re: Can't open ACT DB on new PC

Hi again.... I have downloaded the office dll you sent me and created the test file for it.

unfortunately the "gacutil /l office" command is not being accepted. I tested the gacutil by itself and I'm getting an error saying the term is not recognized as a number of options (command, file, order, etc)

 

A friend is helping remotely and says that if DOS is not accepting the gacutil order then maybe my laptop does not have it installed and if that is the case to ask you for another alternative or any idea of how to download it or install it.... can you help me?

 

Thank you

betty onofre

Administrator
Posts: 694
Country: United_Kingdom

Re: Can't open ACT DB on new PC

[ Edited ]

Check out this KB:
http://kb.act.com/app/answers/detail/a_id/31093

The most common reason is because Password Protected file sharing is on. So, for example, from your machine when you try to browse to the folder that contains the database - it may prompt you for your username and password. If this happens, then make sure you click "Remember Credentials" - this will allow Act to connect on your behalf.

Alternatively, turn off Password Protected File Sharing from the host PC, in Network and Sharing settings.

I wouldn't expect the language to cause a problem.

Nickel Contributor
Posts: 193
Country: Germany

Re: Can't open ACT DB on new PC

The fact that your system doesn't find the gacutil.exe leads to the conclusion that something went very wrong during the installation of Act!.

Try uninstalling and re-installing the application. You don't have to include the SQL server in the process, just the Act! application.

After uninstall, reboot your PC, THEN re-install by starting the Setup with right-mouse-click "as Administrator".

Andreas Schlesselmann
Melville-Schellmann GbR
Germany
www.melville-schellmann.de