Community
Showing results for 
Search instead for 
Do you mean 
Reply

Can't get ACT! 10 to work with Outlook 2007

New Member
Posts: 2
Country: United States

Can't get ACT! 10 to work with Outlook 2007

I have a client who (at my suggestion, no less) has installed ACT! 10 (aka  2008) along with Office 2007 on a Vista notebook.  At first, I couldn't get ACT! to talk to Outlook at all until I saw that you needed to install Outlook first (it had been installed after ACT!).  I uninstalled and reinstalled ACT!.  Now it gives me an error: Object reference not set to an instance of an object. I inst) aalled the latest updates to ACT! (10.0.3.182) and am in the process of applying all the Office updates I can get my hands on.

 

Two things about Outlook that may or may not make a difference:  He has SPAMFighter and Business Contact Manager installed.

 

Any thoughts, or should I just uninstall Office and ACT! and reinstall them (in the right order, this time)?  I'm loathe to do that because of the extreme time involved (my client is no longer on the clock, as it would cost him a small fortune and I feel guilty about technology that I have recommended that simply won't work).

 

Thanks!

Copper Contributor
Posts: 36
Country: United States

Re: Can't get ACT! 10 to work with Outlook 2007

I'm not quite understanding the post:

 

When exactly are you getting the message Object reference not set to an instance of object?

New Member
Posts: 2
Country: United States

Re: Can't get ACT! 10 to work with Outlook 2007

It was happening when I tried to create a new message from ACT!.  "Was" is the operative word.  Once I installed all the Office updates, it seemed to have cleared itself up - at least for now.  When I tried to get to the ACT! address book from Outlook, Outlook would crash.  All of this along with history creation is now working.

 

Thanks for looking into it.

New Member
Posts: 10
Country: United Kingdom

Re: Can't get ACT! 10 to work with Outlook 2007

I am experiencing the same problem. As soon as i connect the ACT! address book, Outlook crashes constantly.

 

After i remove the link, Outlook works perfectly. 

 

I too have Spamfighter installed and feel sure that that is the issue. 

Tuned Listener
Posts: 41
Country: United States

Re: Can't get ACT! 10 to work with Outlook 2007

I see that you are using V 10 so this may not apply, but Act 2009 V 11 causes Outlook 2007 to crash or generate the "Object ref" effor under some conditions. You might check to see if the outlook.exe process is properly closing after an Act address book is added.

 

See the 4th reply in http://community.act.com/sage/board/message?board.id=ACT&message.id=19024#M19024 for details.

New Member
Posts: 10
Country: United Kingdom

Update - Outlook stopped crashing

I have finally managed to get outlook to stop crashing.

 

Once i successfully removed Spamfighter (and that includes from the Exchange server - even it you delete it locally on the PC/laptop, it will not remove completely unless it is also removed from the Exchange), i reconnected the ACT! directory and i've still not had a crash yet.

 

Seems it was spamfighter all along.

 

Only downside is that i now have a lot more spam, but at least ACT! is working with Outlook now.