Community
Showing results for 
Search instead for 
Do you mean 
Reply

Can't delete redundant ACT2012 database.

Accepted Solution Solved
Copper Elite Contributor
Posts: 227
Country: New_Zealand
Accepted Solution

Can't delete redundant ACT2012 database.

I have a faulty Act database in my Act folders which I cannot remove. This is the one that I tried to restore direct from Act 9 to Act2012 without going through the Act11 step, and would freeze when editing/adding companies. (see post http://community.act.com/t5/Sage-ACT/Act-2012-upgrade-now-can-t-add-edit-or-change-Companies/m-p/179...).

When I try to delete this database I get the message : The action can't be completed because the file is open in SQL Server (ACT7).

When I was setting up Act2012 and ran into the problem in the above post, the only way I found to resolve it was to uninstall Act2012 and SQL server and delete all associated files and run a Regclean, then re-install.

When I finally got ACT2012 running on my database, I found I still have a faulty database left in my Act folders from the many unsuccessful update attempts.

I would dearly like to delete it without going through the entire uninstall - reinstall routine.

Thanks. 


Accepted Solutions
Solution
Accepted by topic author GrahamS
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't delete redundant ACT2012 database.

Graham,
This message is referring to being a Windows Admin or Power User, not an ACT! one. Try disabling User Account Control per the instructions in this KB article (will require a reboot):
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2566...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't delete redundant ACT2012 database.

Hello Graham,
If you can open this database in ACT!, then do so and go to Tools > Database Maintenance > Delete Database. If not, then open the ACT! Diagnostics utility (ACTDiag), and detach the database. Once detached, you can browse to the database files and delete them.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Can't delete redundant ACT2012 database.

Thanks. The faulty db is not on the list of available db's for Sage Open Database. The pad file is no longer in the db folder. Possibly it thinks it is open already?

Either way, I need to go with Option 2, but I am not familiar with opening ACTDIAG. Could you step me through that please?

Thanks for your response.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't delete redundant ACT2012 database.

Sure thing:
- Click your Windows Start button, either click Run or go to the Search box on the Start menu, and type "actdiag"
- In ACTDiag, click Databases > Database List
- Locate your database and click to the left of it to highlight
- Right-click on the database and choose the Detach Database option

This disconnects it from SQL Server so you can delete it.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Can't delete redundant ACT2012 database.

Thanks.

It's not in any of the db lists or sql lists in actdiag.

What would happen if I turned off the SQL service under actdiag - Tools - Start/Stop SQL service, then tried to delete the offending file, then restart SQL service?

I'm thinking it can't be very good for the SQL server to be thinking it's running something that it isn't?

Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Can't delete redundant ACT2012 database.

Tried to turn off the sql service under actdiag/tools, couldn't because it told me 'You must be an administrator or power user to stop or start services.' I am the Admin and only user of this PC and database. I am so over Win 7 Pro not knowing who the heck I am!

Any more help please?

Also forced a pad file creation by double clicking the adf file, then tried to open the faulty db normally and it says I am not the owner of the db - I have never changed the owner, wouldn't know how to.

AArrrgh!!

Solution
Accepted by topic author GrahamS
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't delete redundant ACT2012 database.

Graham,
This message is referring to being a Windows Admin or Power User, not an ACT! one. Try disabling User Account Control per the instructions in this KB article (will require a reboot):
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2566...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Can't delete redundant ACT2012 database.

You've got to love Microsoft. With Vista and Windows 7 you may be the administrator but you're not running as the administrator. You have two choices, disabling the UAC as was suggested or temporarily right click on the icon to launch the program and select Run as Administrator.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Can't delete redundant ACT2012 database.

Thanks Roy. The rationale behind that uac logic is just too 'out there' for me!! I'll try it shortly when I've got time to shut down everything in progress and reboot!

Cheers, Graham.

Copper Elite Contributor
Posts: 227
Country: New_Zealand

Re: Can't delete redundant ACT2012 database.

[ Edited ]

Thanks guys! Finally able to delete the faulty Act db file.

Disabled UAC per instructions.

Stopped SQL service under actdiag/tools.

Went to the faulty file's properties, now able to share it with the Administrator, closed out of that.

Right click on the faulty file, delete, GONE!!

Then deleted the ALF and PAD files as well.

Turned the SQL service back on (that's a bit of a trick, you have to go through the "SQL service not connected, can't access/do it anyway" dialogue a couple times before it turns on.

Restored UAC control.

Rebooted, everything works, faulty files all gone.

Whew!

 Thanks for keeping on coming back to me on this Greig.