Community
Showing results for 
Search instead for 
Do you mean 
Reply

Can't Access Shared Database

New Member
Posts: 6
Country: United States

Can't Access Shared Database

Installed Act! on my computer and started adding contacts. Installed Act! on my other computer and went to access my database through my network, but it did not work. I got the typical error message "Cannot access file, might be issue with firewall etc" ON both computers I added Act! under the exemptions in  Windows Firewall. Still would not let me access the database. I shut both firewalls off on both computers. Still didn't work. I moved the database to a public folder on my network, same location I store my quickbooks files that is shared and works just fine. Still I cannot access the database. How can I fix this?
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't Access Shared Database

Hello chased,

Welcome to the ACT! Online Community. I'm sorry to hear about the difficulties you are having accessing your shared database. Take a look at the information in these knowledgebase articles and see if that helps:

 

Error: "The database could not be accessed. In order to access this database, check your network co...

 

Using your Anti-Virus/Firewall Software with ACT! by Sage

 

A couple of other points:

- If using Windows Vista or Windows 7, then do not disable your Windows Firewall, as this will block all traffic to the machine

- You only need to put the firewall exceptions on the machine that is hosting the shared database

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 6
Country: United States

Re: Can't Access Shared Database

I am using Windows Vista.

I added Act! and SQL Server and others to exemptions list as called for in the article.

I ckecked out everything in the article and tried it all. Still doesnt work.

Now I am having trouble logging on to my database.

 

After many errors screens I finally logged on and immediately went to save a copy of my database and recieved this message "the database failed to copy due to the following reason: the system cannot find the file specified"

 

how do i fix this?

 

and also any other tips on what possible could be stopping me from accessing this file from another computer?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't Access Shared Database

Try disabling User Account Control (UAC) in Vista:

 

How to Disable User Account Control (UAC) in Windows Vista®

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 6
Country: United States

Re: Can't Access Shared Database

Still doesn't work. I saved a new database. Now what are the steps in order to share them through a network. Do i copy the file and move the copy to the public folder that is shared by the network? Or due I create a shortcut to the deskstop and move that into the public shared folder?
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't Access Shared Database

I will need to know a little about your setup:

- What O/S is the database host using? What O/S for the client machine?

- How are the two machines networked? Company LAN? Wireless router?

- What version of ACT! are you using?

- What is the exact error message you are receiving when trying to open the database from the client machine?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 6
Country: United States

Re: Can't Access Shared Database

Vista-host

XP-client

Company LAN

Act! Version 12

 

Error:

 The database could not be accessed. In order to access this database, check your network connection and verify that your database server is available. It may be necessary to disable any firewall software on your computer.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't Access Shared Database

Host (Vista)

- Make sure Windows Firewall is on. Add exceptions to the Windows Firewall per the earlier KB article I gave you (actsage.exe, sql, and sql ports)

- Make sure User Account Control is disabled

- Make sure the directory where the database is locate is Public or fully shared (permissions=everyone-full control; security=everyone-full control)

- In the database, go to Tools/Database Maintenance and make sure "Share Database" is checked

- Make sure the host and the client machines are in the same domain or workgroup

 

Client (XP)

- Make sure you can access the host over the network. Go to Start/Run and type in \\[host machine name] - i.e. \\myvistamachine. If this machine cannot access the shared and public directories on the Vista machine, then you have a network permissions issue you must first resolve.

- Once you have verified permissions, then open ACT! and browse through network to directory where shared ACT! database is located. Open the database with the .pad file. You can place a shortcut to the .pad file on the desktop of the client machine.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 6
Country: United States

Re: Can't Access Shared Database

Did all that. My question is now how to correctly share the file. Do I just move the file from the location its on now on the host computer and drop it in the public folder on the host computer. And if so do I just move the .pad file or do I move the .adf file as well.
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't Access Shared Database

The best way to move an ACT! database is to make a backup then restore the backup into it's new location, using the Restore As option. An alternate method is to physically move all the database files per the instructions in the following Knowledgebase article:

 

How to Move an ACT! by Sage Database Without Doing a Backup and Restore

 

My recommendation would be to create a new directory on the C: or D: drive (or whatever drive you use for data) of the host machine, then fully share this directory (Everyone/Full Control), and move the database in there. Then open the database from its new location and make sure the Share Database option is checked.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.