Community
Showing results for 
Search instead for 
Do you mean 
Reply

Automatically add new items not being applied to new fields

Accepted Solution Solved
Copper Contributor
Posts: 13
Country: United Kingdom
Accepted Solution

Automatically add new items not being applied to new fields

Hi all,

 

I have recently added some additional custom fields to our ACT 2009 database, linked to a drop-down list for rapid data entry.

 

However, despite having the "Automatically add new items users enter to the list" setting applied, none of these new fields will accept new items which are typed in, the flashing red exclamation point icon appears.

 

I've tried taking the setting off each drop-down and re-applying it, to no avail. Proof of the setting is in the image below.

 

We have other custom fields with drop downs which were added when we first set the database up, and these appear to work fine.

 

Any ideas how I can fix this behaviour?

 

Thanks,

 

Martin


 


Accepted Solutions
Solution
Accepted by topic author MLUK
‎09-25-2015 03:20 AM
Nickel Contributor
Posts: 205
Country: United_Kingdom

Re: Automatically add new items not being applied to new fields

For the "Contract Length" field properties - do you have "Limit to List" selected?
Trevor Lever

UK - ACT Certified Consultant
www.actpartners.co.uk
trevor@actpartners.co.uk

View solution in original post


All Replies
Nickel Contributor
Posts: 205
Country: United_Kingdom

Re: Automatically add new items not being applied to new fields

Check the field length for "Contract Length" - it may be that it is shorter than the item that the user is adding. This will result in the red exclamation mark appearing.
Trevor Lever

UK - ACT Certified Consultant
www.actpartners.co.uk
trevor@actpartners.co.uk
Copper Contributor
Posts: 13
Country: United Kingdom

Re: Automatically add new items not being applied to new fields

Hi Trevor, thanks for the reply.

 

Hovering over the red ! icon tells me "Only list values are allowed. Please select a value from the list", so I don't think it's that.

Solution
Accepted by topic author MLUK
‎09-25-2015 03:20 AM
Nickel Contributor
Posts: 205
Country: United_Kingdom

Re: Automatically add new items not being applied to new fields

For the "Contract Length" field properties - do you have "Limit to List" selected?
Trevor Lever

UK - ACT Certified Consultant
www.actpartners.co.uk
trevor@actpartners.co.uk
Copper Contributor
Posts: 13
Country: United Kingdom

Re: Automatically add new items not being applied to new fields

Give the man a medal!

 

Thanks Trevor, didn't realise the same functionality was set in two different places.