Community
Showing results for 
Search instead for 
Do you mean 
Reply

Another ...The database could not be accessed

ITL
New Member
Posts: 2
Country: United States

Another ...The database could not be accessed

Like so many others I am getting the "The database could not be accessed" error.  I have read may articles here about how to fix this problem including Article 19640 which has about a dozen suggestions.  I have tried it all with no success. 

 

I have 4 to 5 users accessing an Act 2007 database on our our server (running Server 2003) and all are getting the "the database could not be accessed" error.  I can run Act on the server and access the database with no problems.  Just a reminder that I have tried everything I could find here including checking that Act is setup to share the database, etc.

 

We have been down for a couple of weeks now we'll have to consider other options if I don't get this fixed very soon.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Another ...The database could not be accessed

Option 1 

Are the users able to ping the IP address of the server through the DOS command screen?

If so, then try opening the .PAD file for the database and changing the host name to the IP address of the server.

If not, then the issue is communication between the users and the server.

 

If you change the host name to the IP address in the .PAD you may also want to change the datastore location on the server:

- On the server, make a backup of your database, then close ACT!

- From the Windows Start menu, choose Run and type actdiag

- When ACT! Diagnostics opens, select Databases, then Database List

- Highlight the main database, right-click on it, then select Database Fixes, then Datastore Location

- Verify the path to the database is correct in the top box, then select IP Address and use the same IP address you used in the .PAD file

Note: If all the options are grayed out and you have a red warning that the database is not shared, then the issue is that DB is not properly shared

- Click OK and follow the remaining prompts to complete

 

Option 2

Try moving the database to another location, like a new directory on the root of the hard drive. The following Knowledgebas article provides steps to move an ACT! database:

 

How to Move an ACT! by Sage Database Without Doing a Backup and Restore

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

ITL
New Member
Posts: 2
Country: United States

Re: Another ...The database could not be accessed

Our problem turned out to be a failure of SQL Server Express 2005 SP2 to install on our server. I have read that this is common because Act removes the SQL Admin password for security purposes but that causes this update to fail. Thanks to Nick at Aussie Internet Consulting for posting this on another forum... 1) Go to "SQL Server configuration Manager" 2) Highlight "SQL Server 2005 Services" 3) On the right, double click "SQL Server (ACT7)" 4) Click "This Account" 5) Enter your Windows username and password and click Apply. 6) Install the service pack again. Go to www.windowsupdate.com to do this. (I actually downloaded SQLEXPR.EXE from microsoft.com and did it locally)