Community
Showing results for 
Search instead for 
Do you mean 
Reply

Advanced query not working

Accepted Solution Solved
SUI
New Member
Posts: 3
Country: United States
Accepted Solution

Advanced query not working

I am trying to run an advanced query based on the following criteria:
Zip code starts with 687 OR

Zip code starts with 680 OR

Zip code starts with 686 OR

Zip code starts with 681 AND

SAS (custom field) is equal to "SAS" END

 

However, it is not filtering just the contacts with "SAS" but brining in all contacts with the zip code criteria...

 

Any help would be appreciated.

 

Thank you,

Corey


Accepted Solutions
Solution
Accepted by topic author SUI
‎09-25-2015 03:20 AM
Bronze Contributor
Posts: 1,393
Country: USA

Re: Advanced query not working

Put left paranthesis before the first zip code and right paranthesis after the last zip code.  That should give you the desired results.

John Purdy
ACT! Premium 2016 (V. 18)
Main: HP 9470M 8GB, Win 10 Pro, & Exchange 2013 & Office 365, 32bit
Remote: Dell XPS Ultrabook with 4GB & Win 10 Pro, Office 365 32bit & Exchange 2013

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,652
Country: USA

Re: Advanced query not working

What paraenthesis do you use?

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Solution
Accepted by topic author SUI
‎09-25-2015 03:20 AM
Bronze Contributor
Posts: 1,393
Country: USA

Re: Advanced query not working

Put left paranthesis before the first zip code and right paranthesis after the last zip code.  That should give you the desired results.

John Purdy
ACT! Premium 2016 (V. 18)
Main: HP 9470M 8GB, Win 10 Pro, & Exchange 2013 & Office 365, 32bit
Remote: Dell XPS Ultrabook with 4GB & Win 10 Pro, Office 365 32bit & Exchange 2013
SUI
New Member
Posts: 3
Country: United States

Re: Advanced query not working

That did the trick, John!  Thank you!  I will have to research how the parentheses affect the query results....not familiar with their function.  I was simply following instructions I found on the knowledge base but was not giving me the desired results.

 

Thank you,

Corey