Community
Showing results for 
Search instead for 
Do you mean 
Reply

Activities report very slow to load

New Member
Posts: 2
Country: United States

Activities report very slow to load

When I try to run a report from ACT that contains activities (Company Summary or Activities or report built from scratch) it takes a very long time to load (5-15min) or doesn't load at all. All other reports load fine and the system does not seem slow otherwise.

I have only 15-25 activities per MONTH currently listed in ACT, but we would like to be able to use the calendar function more and be able to run reports on the activities associated with companies. Any ideas as to why this might be happening or what we could do?

 

Here's my system info: 

ACT! by Sage 2008 (10.0) Version 10.0.3.182, Hotfix 1

Windows XP 2002 SP 2

Sony VAIO, Intel

Pentium 4 CPU 3.00GHz

2.99 GHz, 2.50 GB of RAM 

 

Thanks! 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Activities report very slow to load

How many contacts?

Is it as slow in the demo database?

Is the database local or on a LAN?

If on a LAN, is it as slow running from the server?

If on your local machine, I think the VAIO might only have a 5400rpm speed hard drive and hard drive speed is really important to SQL speed. If it's an option, you might look at upgrading to a 7200RPM drive

 

One option that should help is (backup first) removing old cleared activities (say older than 90 days) as per this ACT! Knowledge Base article - http://tinyurl.com/6fkasu

 

Then run database mainenance Check and Repair to reindex the database.