Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act using old History Queue folder

Accepted Solution Solved
New Member
Posts: 28
Country: United States
Accepted Solution

Act using old History Queue folder

We are using ACT 2010 and have been having problems with the Act.Outlook.Service.exe using over a GB of RAM. After investigating, I found that one user (who is also using Act 2010) has his queued emails going into the ACT for Windows 9 HistoryQueue folder rather than Act 12

 

Here is where the emails are going:

C:\Documents and Settings\user\Application Data\ACT\ACT for Windows 9\HistoryQueue

 

Has anyone seen this before? Any idea of a fix?

 

** although it seems to be working, the massive amount of RAM used and the fact that it shouldn't be going to that folder is what is concerning me.

 

Thanks!!


Accepted Solutions
Solution
Accepted by ghollister (Platinum Elite Contributor)
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act using old History Queue folder

[ Edited ]

Your problem may be in the registry. Try this:

- Close ACT! and all MS Office apps (Word, Excel, Outlook)

- Click your Windows Start button, choose Run (XP) or go to the Search box (Vista, Windows 7). Type in regedit

- In the registry editor, drill down to the following key: HKEY_CURRENT_USER\Software\ACT

- Delete any version number folders that are not your currently installed version (i.e 9.0, 10.0, 11.0)

- Under this key, expand OutlookHistoryService, then click Desktop

- In the right-hand pane, find QueuePath and look at the value. If the filepath is not correct for your version, then double-click on it and change the path to be correct for your version. For ACT! 2010, the default path is:

C:\Documents and Settings\(your username)\Application Data\ACT\ACT For Windows 12\HistoryQueue

* (your username) would be your Windows account name

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act using old History Queue folder

Hello rheide,

You need to make sure they are using the ACT for Windows 12 folder. To do this:

- Close ACT! and all MS Office applications

- Open the Task Manager and under the processes tab, end process on Act.Outlook.Service.exe

- Browse to C:\Documents and Settings\user\Application Data\ACT and delete the entire "ACT for Windows 9" folder...leaving only ACT for Windows 12

- Browse to C:\Program Files\ACT\Act for Windows and locate the Act.Outlook.Service.exe file...double-click to restart that service

- Reopen Outlook, reopen ACT!

 

If the user's ACT! preferences were coming from the ACT for Windows 9 folder, then he will be prompted to go through the Setup Wizard when he reopens ACT!. He will then need to redo his user preferences accordingly.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 28
Country: United States

Re: Act using old History Queue folder

[ Edited ]

Greig,

I followed the directions and it just recreates the "Act for Windows 9" folder.

I did it multiple times (and made sure all Office products were closed)

 

When I opened up Outlook, it did NOT prompt me to go through the setup wizard.

 

Any other suggestions?

Thanks!

 

I don't know if this is related or not (let me know and I'll open a new message).
I'm realizing that I'm having the same issue on a growing number of computers in that office. Act.outlook.service is using between 750MB and 1.5GB of RAM until I manually delete the temp emails from the (ACT 9_ folder and then everything starts working again - after restarting act.outlook.service. Today someone had 3700 files in one folder, and 2900 in another (can't remember exactly but one was the holding sub folder and I think the other was the main history queue folder)
Message Edited by rheide on 06-23-2010 06:34 AM
Message Edited by rheide on 06-23-2010 06:35 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act using old History Queue folder

If the ACT for Windows 9 folder is being recreated, this could be an issue with the core preferences file in the ACT! program directory. Try this:

- Manually delete the ACT for Windows 9 folder (and ACT for Windows 10 if it exists) following the previous steps I provided

- Browse to the directory C:\Program Files\ACT\Act for Windows, locate the file Preferences.xml and rename it to "Preferences.xml.old"

- Browse your ACT! 2010 installation directory (disk or download) and navigate to ACTWG(or ACTSTD)\program files\ACT\ActInstallDir\US

- Copy the Preferences.xml file in there and paste it into C:\Program Files/ACT/Act for Windows

- Reopen ACT!, go through the Setup Wizard, then go and check if the correct directory was created this time

 

In regards to the temp files and memory usage created by the ACT! history recording service:

This sounds like the service is continously trying to attach emails that cannot be attached. You may be able to resolve this issue by adding additional error handlers so that these messages will not continously try to attach. Please see the following Knowledgebase article for more information:

 

Troubleshooting Outlook® Integration History Queue Processing Using Error Handling

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 28
Country: United States

Re: Act using old History Queue folder

Greig,

I followed these directions exactly and it did not fix the problem. It keeps creating the ACT for Windows 9 Folder.

In addition to what you have suggested, I have also done the following:

 

gone into C:\Documents and Settings\user\Application Data\ACT\ACT for Windows 12

and deleted all files with the word preferences in the main directory - in the preferences directory I delete uspreferences206.xml and the old file.

 

Here is what happens.

Delete all files (and replace file per your suggestion)

Delete folder (Act for Windows 9)

(while watching the Application data folder) I start Act

And after going through the setup, the second it finishes, the Act for Windows 9 folder comes back up with the HistoryQueue subfolder

 

Any other suggestions?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act using old History Queue folder

Very strange. It seems like something in the install is causing the incorrect preferences folder to be recreated. Instead of trying to chase this down, I would advise uninstall and reinstalling ACT! 2010. Use the ACT! Uninstaller utility found in KB Article 19338. When running the utility, do not check the option to remove the ACT7 instance of SQL. Make sure all programs on the machine are closed when running this utility.

 

After running the utility (and before rebooting), browse to the following directories and delete any ACT! folder you see:

C:\Program Files

C:\Documents & Settings\All Users\Application Data

C:\Documents & Settings\(username)\Application Data

 

Also, if there are any other (username) folders under Documents and Settings besides the currently logged-in Windows user (including Administrator), check the Application Data folder in there and delete any ACT! folders you may see.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 28
Country: United States

Re: Act using old History Queue folder

It's been a long time and I had some time to try this again.

 

I basically come up with the exact same results as before.

 

Close all Apps.

Use the Act uninstall option

Delete all Application Data\Act folders (before reboot)

Reboot

Reinstall

Run Update

Open Act

Check folders (and all 3 - old folders) are back (I think its v9, v10 or v11 and v12) - sorry I'm not at the machine right now.

Send a test email, and the email goes to the v9 history queue.

 

Any other suggestions?

Solution
Accepted by ghollister (Platinum Elite Contributor)
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act using old History Queue folder

[ Edited ]

Your problem may be in the registry. Try this:

- Close ACT! and all MS Office apps (Word, Excel, Outlook)

- Click your Windows Start button, choose Run (XP) or go to the Search box (Vista, Windows 7). Type in regedit

- In the registry editor, drill down to the following key: HKEY_CURRENT_USER\Software\ACT

- Delete any version number folders that are not your currently installed version (i.e 9.0, 10.0, 11.0)

- Under this key, expand OutlookHistoryService, then click Desktop

- In the right-hand pane, find QueuePath and look at the value. If the filepath is not correct for your version, then double-click on it and change the path to be correct for your version. For ACT! 2010, the default path is:

C:\Documents and Settings\(your username)\Application Data\ACT\ACT For Windows 12\HistoryQueue

* (your username) would be your Windows account name

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 28
Country: United States

Re: Act using old History Queue folder

Jackpot. Registry edit did the trick. Thanks!!!