Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act! over a VPN tunnel

Accepted Solution Solved
New Member
Posts: 3
Country: United States
Accepted Solution

Act! over a VPN tunnel

When I connect to the remote server through a Linksys (Cisco) WVR210 VPN router, I get a message that the database cannot be accessed and to check connectivity and firewall settings.

 

When I connect to the same server through a Windows PPTP tunnel (thus bypassing the router, essentially) the database loads perfectly.  

 

I have forwarded TCP port 1433 and UDP port 1434 to my local PC.  Am I missing something?  I read elsewhere about forwarding port 80.  I would rather not forward port 80.  If I need to, I would prefer to modify the required port within Act! and forward to it instead.

 

I am using Windows Vista Business and Act! version 11.  My Windows Firewall is disabled.

 

Thank you in advance.

 

Sam


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
New Member
Posts: 3
Country: United States

Re: Act! over a VPN tunnel

Turns out it was a hostname issue!  I was having a hostname resolution issue on the IPSec tunnel, but not the PPTP.  I edited the .PAD file and replaced the hostname with the IP address.  It works like a charm now.  Thanks!

 

Sam

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Act! over a VPN tunnel

It sounds as if the VPN connection is not resolving the host computer name correctly.  You can try using the server internal IP address in the PAD, for instructions visit the Knowledgebase article below and see the section entitled 'There is a problem on the client machine resolving the name of the computer hosting the database'.

 

Error: The database could not be accessed.

 

In brief: You will need to open your PAD file with Notepad and change the host name to the IP address.

Greg Martin
Sage
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
New Member
Posts: 3
Country: United States

Re: Act! over a VPN tunnel

Turns out it was a hostname issue!  I was having a hostname resolution issue on the IPSec tunnel, but not the PPTP.  I edited the .PAD file and replaced the hostname with the IP address.  It works like a charm now.  Thanks!

 

Sam

New Member
Posts: 3
Country: United States

Re: Act! over a VPN tunnel

Oops.  I tried to get into Act! this morning and am getting the same message.  I verified the tunnel is operational and the .PAD file still has the server's IP address instead of hostname.  Here is the contents of my .PAD file.  192.168.69.2 is the server's IP address and the location points to the .ADF file on the server's local hard drive.

 

<?xml version="1.0" standalone="no"?>
<!DOCTYPE ACTDatabasePADFile>
<!--This file represents a Pointer to an Act Database or [PAD]-->
<ACTDatabase name="FabricareSystemsLLC" host="192.168.69.2" location="C:\Users\Administrator.FABSYS\Documents\ACT\ACT For Windows 11\Databases\FabricareSystemsLLC.ADF" type="Sql" />

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Act! over a VPN tunnel

That's odd, because it worked yesterday... sounds like something in the environment changed

 

First thing is to double check the server's IP, to see if it has changed.  If it has, then you'll need to update the PAD file again.

 

Can you ping the server from your workstation when you are connected through the VPN? 

On XP: click on Windows Start button > select Run > enter the command 'CMD' > it will open a DOS command box > enter the command 'ping ipaddress' (ping 192.168.69.2).  Does it time out or get a response? 

On a Vista/Win7 machine you will click the Windows Start button > enter the 'CMD' command in the Search area > enter the same ping command in the DOS window.

If the requests time out, your computer is not able to find that server/ip address through the network.

If the requests get responses, you'll need to try the other steps in the Knowledgebase article to try and isolate the issue. 

 

 

Greg Martin
Sage
New Member
Posts: 8
Country: Canada

Re: Act! over a VPN tunnel

Hello,

 

I too am getting the infamous (as I have read countless posts) Database cannot be read...please check firewall/ network conenction...

 

My Setup Specs:

- Windows home server

- VPN setup ON the WHS

- SAGE ACT DB installed on SQL Server 2008 R2 on this server

- Firewall disabled (VPN requires it to be)

 

I have setup my VPN using the built-in Windows setup to 'Connect to a workplace'. I can access files and data on that server without issue.

 

So my question is as follows:

 

1. What is the application name that I need to forward to the server with the ACT! DB on it and what ports does it use?

2. is there another application which loads afterwards if so I will need its name as well as ports used.

3. I also use a handful of add-ons for ACt! one of which is Email synch (to pull emails into client records for contact history etc.) I noted there was an ACtEmail.exe (exe name might be off but it was clearly email related) what ports if any does it use?

 

Appreciate any help that can be provided.

 

Rich