Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act is unable to open sync server

New Member
Posts: 1
Country: USA

Act is unable to open sync server

Does anyone have a solution for this error message?  Act is unable to open sync server.  
Copper Contributor
Posts: 53
Country: USA

Re: Act is unable to open sync server

Hi

I had a continuing problem with getting the sync server to start in the master database. If I could get it to start, the sync process would work correctly, but getting it to start was a very rare happening. The following steps finally got it working for me. I am not an ACT! 2008 expert so you may want to wait and see if you get a better suggestion from someone else. However, if no one else responds to this question, give it a shot. You may get lucky. BTW, before I got to this solution, I installed and reinstalled ACT! 2008 a half-dozen times. After installation #2, the sync server would always work right after the installation, and then it would quickly go south on me. If sync server has never activated for you, then you may have installation issues, and my solution will probably not work for you.

PLEASE NOTE: If you feel like skipping some of the steps listed below. For example, I found that just stopping and then restarting the SQL Server (ACT7) service alone did not get the job done. So make sure that you go through the process of opening ACT! 2008 after shutting down the service. This step will be slow, and the program will complain, but for me, it was a necessary step to get a successful conclusion.

1. I kept getting "Could not start sync server. The handle is invalid." when I navigated to Tools\Synchronize\Accept Incoming Syncs in the Master database.
2. Close ACT! 2008.
3. Open services.msc and execute a Stop of the "SQL Server (ACT7)" service.
4. Open ACT! 2008. The program will eventually open. However, ACT! 2008 will not be able to open any databases because the "SQL Server (ACT7)" service is stopped. A file-open box will give you a list of all available .pad files. Double click on any one of them. It won't open, and I am not sure if this step is necessary. I list it because that is what I did.
5. Close ACT! 2008.
6. I waited a couple of minutes, and then I opened services.msc, and did a Start of the "SQL Server (ACT7) service.
7. Then start ACT! 2008, and it should open with the database that you double clicked on in step 4. At this point, when I navigated to Tools\Synchronize, I found that "Accept Incoming Syncs" was checked. I was then able to sync my notebook that has the RDB database with my desktop that has the master database.

My assumption is that this procedure must reset some aspect of either the service or the program that is not correctly set or reset during either the Windows boot up or the ACT! 2008 boot up.

Good luck with it. Hope this works as well for you as it did for me.
Nickel Super Contributor
Posts: 441
Country: UK

Re: Act is unable to open sync server

Do you recieve this on the client end or the server?
 
Tom
Copper Contributor
Posts: 53
Country: USA

Re: Act is unable to open sync server

Hi Tom

Tom Wrote:
>Do you recieve this on the client end or the server?

- My error message came from the master database. Since I have the Standard edition of ACT! 2008, I do not have the client/server version. I think that is the ACT! 2008 Premium edition. Sorry that I didn't make that clear in my initial post.

- My sense of the matter is that either the installation wasn't righteous or that the sync server aspect of the program has become either mis-set or corrupted. Have you ever been able to start the sync server and then complete a synchronization procedure?

-BTW, I never have gotten any error messages logged in the Windows Event log. Have you?
Nickel Super Contributor
Posts: 441
Country: UK

Re: Act is unable to open sync server

When exactly does this happen, what do you click to bring up the message? Just trying to get a clear picture.
 
Tom
Copper Contributor
Posts: 53
Country: USA

Re: Act is unable to open sync server

[ Edited ]
Hi Tom

Tom Wrote:
>When exactly does this happen, what do you click to bring up the message?

1. ACT! 2008 is open and I am in the master database on my desktop computer.

2. I click on Tools in the menu bar.

3. Then, I click on Synchronize in the Tools drop-down list.

4. Then, I click on "Enable Incoming Syncs". BTW, I NOW always leave the check mark beside Enable Incoming Syncs. Not that this probably makes any difference. In the bad old days, I sometimes did this, too, but somehow the program would remove the check mark without any human intervention. Usually, after the computer was rebooted.

5. I accept the default port, 65100 and click on OK.

6. A progress bar flashes on screen, but it is immediately replace by the error message.

Message Edited by Steve on 03-19-2008 09:38 AM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act is unable to open sync server



certified wrote:
Does anyone have a solution for this error message?  Act is unable to open sync server.  



Version of ACT!?
Is that on the Publisher (master) or Sbscriber (remote)?
Is that the correct wording of the error?
Copper Contributor
Posts: 53
Country: USA

Re: Act is unable to open sync server

Hi Mike

Did you mean, me, Steve? Or were you querying the original post?
Nickel Super Contributor
Posts: 441
Country: UK

Re: Act is unable to open sync server

Steve, now this has got confusing, I just realised your problem is not the one on the original post so....
 
To clarify - your problem is that you can't get the sync service to always start.  Is your error message the one in the subject?
 
**Then, I click on "Enable Incoming Syncs". BTW, I NOW always leave the check mark beside Enable Incoming Syncs. Not that this probably makes any difference**      - does this mean Accept Incoming Syncs is already checked when you click on it.  When its checked and you click on it do you get prompted for a port or do you get a message saying sync server stopped?
 
Tom
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act is unable to open sync server



Steve wrote:
Hi Mike

Did you mean, me, Steve? Or were you querying the original post?


The original... which is why I quoted it :-)