Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act does not communicate with SQL server.

Accepted Solution Solved
New Member
Posts: 4
Country: Greece
Accepted Solution

Act does not communicate with SQL server.

Hi,

I am using Act 2008 on a Vista 32 bit machine.

 

Recently I have compressed my hard disk in order to save space and that has  caused various problems. Act seems to be affected by that (although I have uncompressed the Act and the Microsoft SQL Server directories).

My databases are not accessible any more and the error I am getting is the following:

 

"The database <name> could not be accessed. In order to access this database check your netowrk connection and verify that your database server is available . It may be necessary to disable any firewall software on your computer or the server"

 

Even I I try to create a new database it is not possible. The sql server is not accessible. See error below:

 

"Unable to create the database. There was an error connecting to the microsoft SQL server "

 

Actdiag does not work also... for the same reason.

 

I have checked the services and an Act sql service (SQL Server ACT7) appears to run but for some reason it is not linked to Act.

 

 

Please let me know if I am missing something.

 

Thank you

 

George


Accepted Solutions
Solution
Accepted by topic author george.bizas@gmail.com
‎09-25-2015 03:20 AM
New Member
Posts: 4
Country: Greece

Re: Act does not communicate with SQL server.

Finally I had to re-register (I had to find my old activation email from Act)

As soon as I have done that I was able to access the recovered database which is good enough.

 

Thank  you

 

George

View solution in original post


All Replies
New Member
Posts: 4
Country: Greece

Re: Act does not communicate with SQL server.

Sorry,

I forgot to mention that I have unistalled Act reinstalled it but this did not fix the problem.

I have even tried to istall sql server 2005 from microsoft but no joy.

 

George

Bronze Super Contributor
Posts: 1,544
Country: United_Kingdom

Re: Act does not communicate with SQL server.

[ Edited ]

George,

You should uninstall Act! + SQL (ACT7 instance) and .NET.

Also make sure your database is not compressed.

Then reinstall Act!.

HTH


David Shaw
Act! Certified Consultant since 2001
Office:    +44 (0)1483 714507
Mobile: +44 (0)7977 567 318
E-Mail:    dshaw@act4u.org 
New Member
Posts: 4
Country: Greece

Re: Act does not communicate with SQL server.

Hi David,

 

Thank you for your answer. It seems that I am getting somewhere.

I have done all that you have sugested rebooted and now I don't see that sql error.

 

However, when I try to access my old database I have the message:

 

"Could not find a database called <name> on host <computer name>"

 

 

When I try  to create a new database I have the message:

"There are not enough licenses in this database to allow you to login. Please contact your Administrator"

 

And when I try to recover my database from a recent backup the procedure goes smoothly the new database is created but I have the message when i try to open it:

"To finalize the registration ,the database administrator must login first."

 

I think the last option is the one I have to explore. Ideally I would like to have access to my old database but a recent backup would do.

 

Any ideas?

 

George

Bronze Super Contributor
Posts: 1,544
Country: United_Kingdom

Re: Act does not communicate with SQL server.

Hi George,

 

You might try opening your database using the .adf file after deleting (or renaming the .pad file).


David Shaw
Act! Certified Consultant since 2001
Office:    +44 (0)1483 714507
Mobile: +44 (0)7977 567 318
E-Mail:    dshaw@act4u.org 
Solution
Accepted by topic author george.bizas@gmail.com
‎09-25-2015 03:20 AM
New Member
Posts: 4
Country: Greece

Re: Act does not communicate with SQL server.

Finally I had to re-register (I had to find my old activation email from Act)

As soon as I have done that I was able to access the recovered database which is good enough.

 

Thank  you

 

George