Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act Pro 16 upgrade database problem

New Member
Posts: 7
Country: USA

Act Pro 16 upgrade database problem

I'm upgrading from Act 2010 to Act Pro 16.  The install seemed to go fine until I try to update my database.  I'm gettng thr following error.

 

Changed database context to 'master'.Changed database context to 'ComfortTechnology'.
*********** Schema Update failed **************
*********** Exception message follows *********

* Sql Server Product Version Check Failure - Version Running Is Not a Supported Version. Exiting from update.
Process ID 55 has raised user error 50000, severity 25. SQL Server is terminating this process.
A severe error occurred on the current command.  The results, if any, should be discarded.

Schema Update failed.

 

I've tried searching for this error, but haven't found any references to it yet.  Running services.msc tells me SQL server (Act7).  No idea what to do with that though.

 

Thanks for any help or suggestions.

Moderator
Posts: 704
Country: USA

Re: Act Pro 16 upgrade database problem

pitman9,

 

  It sounds like your version of SQL server did not update properly.  When you go into Add/Remove programs, what versions of Microsoft SQL Server do you see?

Billy Clark
Swiftpage
Act! Knowledgebase: http://kb.act.com
New Member
Posts: 7
Country: USA

Re: Act Pro 16 upgrade database problem

That was the problem.  I contacted SwiftPage for help.  It took us about 2 hours or so to rip out the old SQL server and get the new one in.  But the database updated afterwards and I was a happy camper.

 

Now that I've used it for a few days it seems that the SQL server won't start automatically as I've had to start it every day before Act will load my database.

Nickel Contributor
Posts: 249
Country: United_Kingdom

Re: Act Pro 16 upgrade database problem

You could try and change the ACT7 service startup type  to Automatic (Delayed Start) and see if that helps.

Or create a bat file and then you could add the following:-

sc config mssql$act7 start= auto
net start mssql$act7

 

or  for to change to a delayed start

sc config mssql$act7 start= delayed-auto
net start mssql$act7

 

You could then run this manually or create a shortcut and hen add it to your startup folder. You may need to change the shortcut to run as administrator if you have UAC enabled this can be done by right mouse clicking on the shortcut , on the shotcut tab click on Advanced button and add a tick to the Run as Administrator.

 

I hope this helps

Chris