Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act Link for Palm errors after install of 10.0.2

New Member
Posts: 4
Country: USA

Act Link for Palm errors after install of 10.0.2

After upgrading from 10.0.1 to 10.0.2, i receive an error in Act Link for Palm.  I have unstalled and reinstalled both Act 10.0.2 and Act Link for Palm, but still get a .NET error each time.  Act Link for Palm worked fine in the previous release 10.0.1.   Anyone else run into this issue?
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act Link for Palm errors after install of 10.0.2

What error?

Have you tried the link from the full install rather than the update?

New Member
Posts: 4
Country: USA

Re: Act Link for Palm errors after install of 10.0.2

After the upgrade, i clicked on the Palm Hotsync and got a .NET error.  I can reinstall it and get the exact message.  I did uninstall it and reinstall it (Act Link for Palm) from the original CD but got the same error.  I had a similar error when trying to use CompanionLink.  They supplied a patch, but that's another issue altogether.  I would really like THIS to work since it worked before.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act Link for Palm errors after install of 10.0.2

Once again... what error?

 

As you're an ACC according to your icon, have you asked in the ACC groups?

New Member
Posts: 4
Country: USA

Re: Act Link for Palm errors after install of 10.0.2

Yes, I'm an ACC and a .NET developer as well.  I have the errors in screen shots.  Appears to be .NET 2.0 related.  Have had no success with anyone on this. 

 

Error:

 

fail
Could not load file or assembly 'Act.Devices.Entities, Version=10.0.237.0, Culture=neutral, PublicKeyToken=ebf6b2ff4d0a08aa' or one of its dependencies. The system cannot find the file specified.

There's an error in ActPalmLinkSetup.exe which is recorded in the Event Log as well as a log file. The error relates to kernel32.dll (Win XP OS file). 

 

Again, Act Link for Palm worked fine in 10.0.1 but fails in 10.0.2 despite uninstall/reinstall of all components, registry cleaning, etc.

 

I'm just going to roll back to 10.0.1 if i don't hear anything today. 

 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act Link for Palm errors after install of 10.0.2

New Member
Posts: 4
Country: USA

Re: Act Link for Palm errors after install of 10.0.2

 

 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act Link for Palm errors after install of 10.0.2

There might be some corruption in the .Net install.

This is a procedure I wrote to get the most clean install possible:
Uninstall any version of ACT! from Windows Control Panel | Add/Remove Programs
Use the Uninstaller.exe from the ACT! KB 19338 (the exe, not the manual uninstall)
Uninstall .Net Framework (all versions) - this does NOT apply to Vista users as .Net 2.0 is part of the OS and can't be uninstalled
Uninstall any MS SQL items from the Control Panel if still there
Uninstall MSXML Services from Control Panel if it's still there
Perform a Selective restart with MSCONFIG as per ACT! KB 14499
Install .Net 2.0 Framework (only 2.0 for ACT! 9/10) from MS web site (only XP, not Vista)-
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
Manually install MS SQL as per ACT! KB 19386
Install ACT! 10.02 full install
Install ACT! link for Palm from the 10.02 install
Restore from Selective Startup Mode with MSCONFIG
Reboot