Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act 2011 extremely slow to open databases

Accepted Solution Solved
Copper Contributor
Posts: 5
Country: USA
Accepted Solution

Act 2011 extremely slow to open databases

Just got our hands on Act 2011, and are having problems with opening any database. Act comes up to the initial "New Database/Open Database" screen quickly, but once you open a database Act hangs for about 20 minutes before it comes up to a usable state. I've installed it stand-alone and in a client/server model with the same results. The database I'm opening is brand new and has one contact. During the time Act is hung, there is no excessive CPU or disk activity, no dramatic increase in memory usage, and every other aspect of the system is still responsive. All systems were using the MS SQL 2008 Express R2 server that came with Act 2011.

 

Any clues?

 

Hardware used:

 

Standalone  -- Dual-core 2.66GHZ, 2GB RAM, Windows XP Pro SP3, SATA HDD

Server -- Dual CPU 2.8GHZ Xeon, 4GB RAM, Windows Server 2003 SP2, 10K RPM SCSI HDDs (This was also tried as a standalone system with the same results)

Client -- Single CPU/HyperThreaded 3.4GHZ, 1GB RAM, Windows XP Pro SP3 , SATA HDD


Accepted Solutions
Solution
Accepted by topic author LeeH
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 5
Country: USA

Re: Act 2011 extremely slow to open databases

I tried renaming the "ACT Data" and even its parent "ACT" folder on two machines, and neither resolved the issue. I also de-installed (not just disabled) all anti-virus and anti-ad/malware software, disabled firewall completely and still had the same issue.

BUT, after some trial and error, I've found the hang up! The problem is the "Welcome" screen. While poking around the preferences, I decided to change the startup view to "Contacts", since that's what our sales staff starts with now anyways. Once that was set, Act starts up to the Contacts screen in the expected amount of time. Once loaded to that point, a switch to the Welcome screen yields the previously mentioned 20-minute delay. I don't know what aspect of that screen is creating the delay, but that appears to be the culprit. Is there some content it pulls from the Internet that our stateful firewall + transparent web proxy might be interferring with?

Solution: Set startup view to something other than Welcome screen. Remove Welcome screen from side navbar using the menu at the bottom of navbar.

One last question: Is there a way to disable this screen entirely? As in, so it doesn't even show in the "View" menu?

View solution in original post


All Replies
Copper Contributor
Posts: 5
Country: USA

Re: Act 2011 extremely slow to open databases

No ideas? Is there any other information I can provide to help diagnose this issue? Has anyone else seen this sort of problem?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act 2011 extremely slow to open databases

Hello LeeH,

Welcome to the Sage ACT! Online Community. This is not typical of ACT! 2011. Do you have the same firewall/antivsrus running on all these machines? Try adding program and port exceptions for ACT! and SQL per KB Article 25125. Also, I have seen where a damaged preferences file can cause a database to load slowly, but it is unusual for it to happen on multiple machines. As a test, though I would try manually rebuiding this file on one of the XP machines. To do this:

- Close ACT! and all MS Office apps (Excel, Word, Outlook)

- Click Start, the Run, then type in %appdata%

- In the Application Data directory, open the ACT folder.

- You should see a folder called ACT Data. Rename this folder to ACT Data OLD

- Restart ACT! and test

* Please note that the above process will reset all ACT! preferences to their default. You can redo the preferences when prompted to go through the setup wizard when re-opening ACT! and also by going to Tools > Preferences in the program.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 5
Country: USA

Re: Act 2011 extremely slow to open databases

Thanks for the reply!

None of these systems have firewalls enabled, we're a small network and firewall at the border. All XP systems are running AVG anti-virus and usually Ad-Aware, no anti-virus/Ad-Aware is installed on the Win2k3 server. The Win2k3 system also doesn't have Office installed at all, it's basically a headless server.

I'll try resetting the preferences on the XP client today and post results.
Solution
Accepted by topic author LeeH
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 5
Country: USA

Re: Act 2011 extremely slow to open databases

I tried renaming the "ACT Data" and even its parent "ACT" folder on two machines, and neither resolved the issue. I also de-installed (not just disabled) all anti-virus and anti-ad/malware software, disabled firewall completely and still had the same issue.

BUT, after some trial and error, I've found the hang up! The problem is the "Welcome" screen. While poking around the preferences, I decided to change the startup view to "Contacts", since that's what our sales staff starts with now anyways. Once that was set, Act starts up to the Contacts screen in the expected amount of time. Once loaded to that point, a switch to the Welcome screen yields the previously mentioned 20-minute delay. I don't know what aspect of that screen is creating the delay, but that appears to be the culprit. Is there some content it pulls from the Internet that our stateful firewall + transparent web proxy might be interferring with?

Solution: Set startup view to something other than Welcome screen. Remove Welcome screen from side navbar using the menu at the bottom of navbar.

One last question: Is there a way to disable this screen entirely? As in, so it doesn't even show in the "View" menu?
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act 2011 extremely slow to open databases

Lee,

I'm glad to hear you were able to resolve the issue. Yes, the Welcome screen does try to download some external content on startup, so a firewall or proxy could slow or prevent the loading of this screen. Unfortunately, there is not a way to remove access to the Welcome screen...the only workaround is for each user on each machine to choose another startup screen in their Preferences. Thanks for taking the time to share your solution with the Community! I will be updating our Knowledgebase with this information.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Act 2011 extremely slow to open databases

Lee,

Let me correct myself on the Welcome Screen question. You can remove it from the NavBar on the left by clicking in the double arrows at the bottom right corner of the NavBar, choosing Navbar Options, and unchecking Welcome. Sorry about the previous misinformation.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 5
Country: USA

Re: Act 2011 extremely slow to open databases

Yep, done that. Found out you can also remove it from the "View" menu by choosing:

 

Tools -> Customize -> Menus & Toolbars -> Left-click "View" menu, Right-click "Welcome", choose "Delete" from pop-up menu.

 

As for the Welcome screen downloading external content, seems unecessary. I replaced the "ACT_Home.html" file with a blank HTML document. This worked great, I'll be doing this on all subsequent installations prior to first launch.

 

Thanks much for all your help, hope this info gets contributed back towards the knowledge base and developers!

LS
New Member
Posts: 1
Country: USA

Re: Act 2011 extremely slow to open databases

I have a similar problem which ACT has told me they are working on a fix.  After opening my data base if I e-mail from the ACT program the system grinds to a very slow response time in clearing/rescheduling activities and going from contacts to calendar.  Anyone know if that fix has been done?  It could be the same issue.

New Member
Posts: 1
Country: USA

Re: Act 2011 extremely slow to open databases

Lee,

 

Thanks for this, it was very helpful for a client of ours. I also think replacing the HTML file contents is a great way to completely solve the issue if that page is not needed (in our case it is not).

 

I was not however able to find the ACT_Home.html file you mentioned. If you (or anyone else reading this) knows the default location and file name of the Welcome screen page and can provide, I would greatly appreciate your help.

 

Thanks,

Mike