Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act 2009 Trial - cannot access shared database

Accepted Solution Solved
New Member
Posts: 3
Country: United States
Accepted Solution

Act 2009 Trial - cannot access shared database

 

Is there a limitation in the trial which prevents networking across to another PC?

I am testing a trial version of Act 2009 standard (11.0) by simulating a customer's non-domain (workgroup) environment.  The customer presently has Act 2006 on a XP Pro Box.  I am working with two clean PC's with their respective operating systems.  I installed Act 2005 (the closest thing I had to the customer's Act), applied the Act 7 patch, imported a database, removed Act 2005 (leaving the database in tact), followed by installing the Act 2009 trial.  I didn't test sharing with Act 2005 because the customer bought a new Vista laptop and Act 2005 won't work on Vista.

Can someone clarify how to share the database?  I'm having trouble with sharing a database from a WinXP Host so a Vista Home Premium Sp1 box running Act 2009 can access it.  The XP Host runs Act2009 and accesses the database without any difficulties.


Sage doesn't make it exactly clear where the Windows share should be established.

For example I have the CONTACTS database in C:\Documents and Settings\jsmith\My Documents\Act for Win 7\Database.  I have assigned full control permissions to the Vista user, making username/password combinations the same on both pc's.

When I share the database from within Act 2009, a share is created in a subfolder CONTACTS-database files.  Full path is:

C:\Documents and Settings\jsmith\My Documents\Act for Win 7\Database\Contacts-database files

How does the PAD file resolve?  I use the IP Address of the XP Host, but the path is the original location of the database file, which is C:\Documents and Settings\jsmith\My Documents\Act for Win 7\Database

I would think this path should be the path relative to the share.  For example, if I create a share to the Database folder (above, calling it "database") and map Z: to the database share that would make my contacts database location in the pad file z:\ ?

The test setup are clean Windows XP / Vista Installs, no antivirus, no third party firewalls, and Windows firewalls are shut down.  I have applied the NTLM registry adjustment on the Vista Sp1 box, and I can read and write files to a test share I created on the XP Box from the Vista PC.  I have disabled simple file sharing on the XP box.

I have also applied the cliconfg settings, and verified tcp/ip connectivity is enabled with Sql configuration from box boxes.

A wireshark trace running from the XP Box shows udp SQL datagram packets from the Vista box to the XP box, walking up from 51090 to 51094 and 61247 to 61254 before Act errors out with the familiar message:

"The database CONTACTS could not be accessed.  In order to access this database check your network connections…"

Act Diag running on the XP Box shows the Sql test is unable to create a test database when I set the drive to Z: (the database share).  I have full control to the database share.

 


Accepted Solutions
Solution
Accepted by topic author eric7628
‎09-25-2015 03:20 AM
Bronze Contributor
Posts: 955
Country: Australia

Re: Act 2009 Trial - cannot access shared database

Eric,

 

Try turning off Windows firewall via the services part of windows and see if you are able to access the database as this is what it sounds like the block is coming from. Failing this could the problem be in the antivirus software blocking access?

 

The other thing you might try is to move the database to the c:\actdata of the machine you want to share it from and then copy the .pad file to the machine you want to open it from

Paul Buchtmann
pbuchtmann@ozemail.com.au Australia
Australia's First ACT Consultant (1989)

FREE Record History to change default to Call or To-Do for ACT! 2010-2012 versions. Custom versions also available.

View solution in original post


All Replies
Solution
Accepted by topic author eric7628
‎09-25-2015 03:20 AM
Bronze Contributor
Posts: 955
Country: Australia

Re: Act 2009 Trial - cannot access shared database

Eric,

 

Try turning off Windows firewall via the services part of windows and see if you are able to access the database as this is what it sounds like the block is coming from. Failing this could the problem be in the antivirus software blocking access?

 

The other thing you might try is to move the database to the c:\actdata of the machine you want to share it from and then copy the .pad file to the machine you want to open it from

Paul Buchtmann
pbuchtmann@ozemail.com.au Australia
Australia's First ACT Consultant (1989)

FREE Record History to change default to Call or To-Do for ACT! 2010-2012 versions. Custom versions also available.
New Member
Posts: 3
Country: United States

Re: Act 2009 Trial - cannot access shared database

Paul, shutting off the Windows Firewall/ICS service resolved this, I am now able to connect.  Thank you, I guess the Off setting in the Windows XP firewall really isn't "off."  These were test PC's - no antivirus or security software installed whatsoever, and the PAD file with the original path to C:\Documents and Settings\jsmith\My Documents... (in my prior post) was the correct path, not a relative path as seen from the Vista workstation.  Also I removed the 'database' share leaving only the one Sage/Act created and it still loads.

 

I re-enabled the firewall on the XP Desktop, and as per

http://support.microsoft.com/kb/914277

I placed an exception for sqlbrowser.exe, however it stilled failed to connect.  I enabled Windows firewall logging in advanced properties, andconfirmed the firewall is dropping udp packets 51557 thru 51568 from the Vista Box.  Ideally I'd like to run with the firewall on soit appears I'll have to insert some port exceptions.  I'll repost when I have more to report.

New Member
Posts: 3
Country: United States

Re: Act 2009 Trial - cannot access shared database

More information if anyone is interested:

Based on this post, and user feedback on the same page,

http://www.mattwoodward.com/blog/index.cfm?event=showEntry&entryID=01930619-FD0A-4F02-31B1BFC7D1D9A4...


The instance of Sql Server Express 2005 gets installed and seems to pick it's own fixed port at random.  Mine was set to 1050, when I changed it to 2301 it started working.

SQL Configuration Manager, click Protocols for Act7, Right Click TCP/IP, select Properties,
click the IP Addresses Tab, scroll down to IPAll, look for the field TCP Dynamic Ports, the value
I had was 1050.  I changed it to 2301, rebooted, now the Vista workstation connects to the Act database and the Windows firewall is running.  This was Act 2009 upgraded from Act 2005, your SQL Instance name may vary.

Bronze Contributor
Posts: 955
Country: Australia

Re: Act 2009 Trial - cannot access shared database

Eric,

 

I have found this a lot with windows that off is not always off and you have to look under the hood more regularly than one likes to.

 

Glad it worked for you

Paul Buchtmann
pbuchtmann@ozemail.com.au Australia
Australia's First ACT Consultant (1989)

FREE Record History to change default to Call or To-Do for ACT! 2010-2012 versions. Custom versions also available.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act 2009 Trial - cannot access shared database

Eric, you might also have a read of this ACT! Knowledge Base article - http://tinyurl.com/4q46e3

 

It's related to the XP firewall, but the apps and ports that need access are still the same.

Moderator
Posts: 4,395
Country: USA

Re: Act 2009 - cannot access shared database

Moved AndyStumpf's post to its own thread for greater exposure.