Showing results for 
Search instead for 
Do you mean 

Act! 2007, Version 9 Error Issue with Ole/DB Forms

New Member
Posts: 1
Country: United States

Act! 2007, Version 9 Error Issue with Ole/DB Forms

[ Edited ]



The issue at hand is an OLE/DB Forms issues with an error. This installation had upgraded years ago from Version 4 to Act! 2007 Verion 9.03.


This error was never apparent until trying to create a remote database to sync. Upon further investiagation, by using the Actdiag tool, trying to rebuild the OLE/DB form reports, produced the same error. Going into advance settings, I was able to turn off OLDE/DB forms and was able to rebuild and create the remote database. However, upon creating the database on the other computer from the remote database, the same error would come up. Here is what the error looks like:


Incorrect syntax near ')'

Incorrect syntax near the keyword 'with'. If this statment is common table expression, or an xmlnamespaces clause, the previous statement must be terminated with a semicolon.


The number of orphaned users fixed by updating users as 0.

The number of orphaned users fixed by adding new logins and then updating users was 0.

.....The above last 2 lines are repeated a number of times.

***Setting rights no prcedures...

***Setting rights on tables and views....


I had contacted Sage and after long investigative work (saving and copying, etc.) this issue could not be resolved and was told that the database would have to be sent to them for repair.


I am very familar with SQL databases and I was wondering if there is a backdoor way or some tool that I could use to repair this error. I have searched in vain. Would an upgrade to ACT! 2009 fix this issue?


The computer that runs this database is Windows XP Pro, SP3.


Any help in this matter would be highly appreciated.








Message Edited by alanh102 on 03-13-2009 08:51 AM
Posts: 4,395
Country: USA

Re: Act! 2007, Version 9 Error Issue with Ole/DB Forms

If this is really a database issue, I doubt upgrading will fix the issue.  I am assuming you were able to create a remote database from the demo database?  If you want to avoid database services, you can create a new database (not empty copy) and import the database.  This can help narrow it down to a structure or data issue.  If you are able to create a remote after the import, then you know its a structure issue.  You will need to recreate an custom fields in the new database.