Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act 2006 to Act 2010 upgrade running very very slow. New pcs

Accepted Solution Solved
New Member
Posts: 2
Country: United States
Accepted Solution

Act 2006 to Act 2010 upgrade running very very slow. New pcs

Act 2010 was upgraded and installed on a new server and two new computers.  We were told by Sage representative to expect a 20-30 percent performance boost.  Feels exactly the opposite, loading times up to and over a minute.  I have read other posts about hard drive speeds and other resources, but these  computers all exceed well and above what Act 2010 requires. (Quad Cores/Core 2 Duos with 4/8gigs of ram 3ghz processor 7200 rpm hard drives etc)

 

 

Tested the network and will even try a gigabit switch in a day but is there something i am missing or do not know of that causes slow performance over a network?  Also there are no firewalls, anti virus programs on these computers as they do not connect to the internet so basically these pcs run microsoft office, act 2010 and that's it. 

 

It just feels like performance wise that we went very backwards on these upgrades and I am just hoping its something I am missing here.  Its disheartening to talk to installation tech saying that 30 sec to 1 min load times is reasonable in this new version of Act.  Just really not what we were expecting so I am hoping some of you have experience this and found a fix for this.


Accepted Solutions
Solution
Accepted by topic author farishk
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: Act 2006 to Act 2010 upgrade running very very slow. New pcs

I'll start off by noting that the launch time of up to a minute is about what I would expect and my understanding is that it's done to improve general performance by pre-loading the most commonly used parts of the program. Also make sure you have all the hotfixes installed. There was some early complaints regarding performance with ACT! 2010 that were resolved by one of the hotfixes. You can check by going to Help | About ACT! and it should be at Hotfix 4.

 

I have seen a single bad NIC driver or a bad NIC card drag down the performance of the whole network so that would be a good thing to check. With the later versions of the ACT! program such as ACT! 2010, the performance over the network should be comparable to a local database. Because the ACT! program no longer directly controls the database, that task is now done by the SQL Server. The ACT! program basically requests data from the SQL Server and then receives the data back. That means the database heavy lifting is being done by the server and can't be ruled out as the source of you problem.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129

View solution in original post


All Replies
Solution
Accepted by topic author farishk
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: Act 2006 to Act 2010 upgrade running very very slow. New pcs

I'll start off by noting that the launch time of up to a minute is about what I would expect and my understanding is that it's done to improve general performance by pre-loading the most commonly used parts of the program. Also make sure you have all the hotfixes installed. There was some early complaints regarding performance with ACT! 2010 that were resolved by one of the hotfixes. You can check by going to Help | About ACT! and it should be at Hotfix 4.

 

I have seen a single bad NIC driver or a bad NIC card drag down the performance of the whole network so that would be a good thing to check. With the later versions of the ACT! program such as ACT! 2010, the performance over the network should be comparable to a local database. Because the ACT! program no longer directly controls the database, that task is now done by the SQL Server. The ACT! program basically requests data from the SQL Server and then receives the data back. That means the database heavy lifting is being done by the server and can't be ruled out as the source of you problem.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 2
Country: United States

Re: Act 2006 to Act 2010 upgrade running very very slow. New pcs

I didn't mean to hit accept the solution on these forums, in fact this is not acceptable at all.

 

As a test , we installed act 2006 onto the same network/server/computers.  3-5 second load up and login times on act2006 vs 1 min in act 2010.  I dont know what they have done over the years but I was upset when i spoke to sage tech support and the response i got today is was as the advances have been made in Act, the program has gotten bigger so expect a slow down.  Our office computers are much more advance vs what we had 4 years ago, I am talking 1.5 ghz 512 meg machines vs 3ghz core2duos with 4gigs of ram. 

 

These computers are much, much more advance in architecture than what we were using in 2005/2006.   Act has very minimal system requirements, but it seems to me that this program is poorly program and with two sage support people telling me that this long of a wait for the program to load is acceptable.  

 

It absolutely isn't.

 

 

I have dealt with several different SQL based computer programs that are just as complex and have as much data stored as Act 2010 and none of them are as slow as this program.  

 

Fyi, I do not own this company i am discussing.  I am a computer systems integrator who has been pushing ACT as a software package since 2000.  It saddens me that I can no longer recommend this product.  Hopefully Sage takes this kind of commentary and fixes Act into a better performing product. 

Copper Contributor
Posts: 9
Country: United States

Re: Act 2006 to Act 2010 upgrade running very very slow. New pcs

I had a similar problem untill I turned off the firewall on the server.  Load time went from 30-60 seconds to less than 1 second!  I do not know if I can leave the server firewall off but we do have a hardware firewall.
New Member
Posts: 1
Country: USA

Re: Act 2006 to Act 2010 upgrade running very very slow. New pcs

We paid thousands of dollars to upgrade to the premium, for 7 licenses, and paid several more thousands to have a consultant come to Clovis CA to install, and train us for many days.

 

Here are our frustrations, and thoughts woudl help!

 

1.  Does not Sync, Sage said that is a problem, and they cant fix it.

2.  Letter Templates. You cannot use a template and save it, it just disappears!

3.. Very Slow. When a client returns my call, and i try to type notes, there is a major delay, and even looking up files is super slow. We do have 26,000 contacts in our data base, but SAGE assured me that would not be a problem.

 

Any suggestions?

 

Skip Rollf

Sr. Investment Advisor

Sperry Van ness

Nickel Elite Contributor
Posts: 934
Country: USA

Re: Act 2006 to Act 2010 upgrade running very very slow. New pcs

Hello Skip,

I know we need to try to resolve issues on this forum, but this sounds like you need someone to take a look see.

Had similar probs when I went from ACT2008 to ACT2010 but all is good now thanks to Sage Support.

I would be willing to asssist you with this problem, no charge, then we can post resolve back on this forum post.

 Cheers - FSB

Bill Williams - Owner/Consultant/Trainer at Fill Staff "ACT! FOR RECRUITERS"
Manage Your ACT! Backups http://fillstaff.com/backupfolderspro.html - FREE
BIG ACT! LAYOUTS for Larger Monitors www.bigactlayouts.com
Protect your Files & Folders with Folder Lock Pro by New Software http://download.cnet.com/Folder-Lock/3000-2092_4-10063343.html