Community
Showing results for 
Search instead for 
Do you mean 
Reply

Accessing Sage Via VPN

New Member
Posts: 8
Country: Canada

Accessing Sage Via VPN

Hello,

 

I am getting the infamous (as I have read countless posts) Database cannot be read...please check firewall/ network conenction...

 

My Setup Specs:

- Windows home server

- VPN setup ON the WHS

- SAGE ACT DB installed on SQL Server 2008 R2 on this server

- Firewall disabled (VPN requires it to be)

 

I have setup my VPN using the built-in Windows setup to 'Connect to a workplace'. I can access files and data on that server without issue.

 

So my question is as follows:

 

1. What is the application name that I need to forward to the server with the ACT! DB on it and what ports does it use?

2. is there another application which loads afterwards if so I will need its name as well as ports used.

3. I also use a handful of add-ons for ACt! one of which is Email synch (to pull emails into client records for contact history etc.) I noted there was an ACtEmail.exe (exe name might be off but it was clearly email related) what ports if any does it use?

 

 

Appreciate any help that can be provided.

 

Rich

Nickel Contributor
Posts: 173
Country: Australia

Re: Accessing Sage Via VPN

This would most likely be a DNS issue on your VPN, the host computers DNS namewill not be resolving on your computer on the VPN, try pinging it.

Note: This method to access an ACT! database across a WAN is not a supported method to access the database and may lead to data corruption. You should use ACT Sync to acheive mobile access for ACT!
Travis Rosevear ACC for
Act Today Australia and New Zealand
New Member
Posts: 8
Country: Canada

Re: Accessing Sage Via VPN

Hello,

 

firstly thanks for your repsonse. 

 

I am not 100% sur eif you're referring to the Server not being able to resolve the rmeote machines name or the remote machine not being able to resolve the servers name.

 

 

I can ping the servers name and I get a ttl response that is well within normal.

 

 

Rich

Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Re: Accessing Sage Via VPN

Make sure the following ports are opened up both ways:

 

TCP: 1433

UDP: 1434

TCP: 8112

TCP: <dynamically assigned port for ACT!> //you can get this from ActDiag->Server Security

 

Your problem sounds like a port blocking issue to me.

 

HTH

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
New Member
Posts: 8
Country: Canada

Re: Accessing Sage Via VPN

fantastic thank you. are these all for the main SAGEACT.exe or should it be for any exe?

Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Re: Accessing Sage Via VPN

You can also open up for the following exe's as you've suggested as well:

 

ActSage.exe

C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.ACT7\MSSQL\Binn (64bit OS)

C:\Program Files\Microsoft SQL Server\MSSQL10_50.ACT7\MSSQL\Binn (32 Bit OS)

 

Ensure that the SQLBrowser if visible.

 

Accessing the ACT! dB via VPN is not recommended since you will have severe performance issues. I think dB health should be ok since the transact log will ROLLBACK any unsuccessful COMMIT calls, however if you have file attachments the same can not be said and you could get file attachment corruptions.

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
New Member
Posts: 8
Country: Canada

Re: Accessing Sage Via VPN

Hello All,

 

So I wanted to confirm that this issue is not resolved for me. I will reconfirm my setup as well as itemize the steps I have tried.

 

 

1. Setup is as follows:

 

3 Clients using WIN7

1 Server Runnining Win2k3 WHS w/ VPN Enabled & also doubles as the DB server for ACT!

Act Version: Sage ACT! Pro 2011 Version 13.0.401.0, Hot Fix 2

D-Link Router: Forwarded Application/ server ports to my Server for external VPN

opened ports for applications

 

 

2. Details of the problem: I am getting the error Database cannot be opened Check network .....

 

 

3. Items I have tried to do to correct this issue:

 

1. I have telneted into my SQL box using the custom port which I was able to extract by looking at the SQL config. manager. It appears that this is the only PORt which the server is listening on. ---This connected in the office

 

2. The PAD file has been updated to include the IP of my server rather than the host DNS name- confirmed working in the office, still generates the network error outside of the office

 

3. I can connect to any and all network shares while inside and outside of the office. Read-write permissions

 

Any ideas?

 

 

New Member
Posts: 8
Country: Canada

Re: Accessing Sage Via VPN

This has now been corrected. The windows firewall was preventing the traffic. Despite the fact that I disabled it for some reason that idn't do much. I re-enabled the windows firewall and was able to fin that SAGE ACT was listed twice in the firewall application lists. Enabling it from both public & private networks is what allowed ACt! to connect.

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Accessing Sage Via VPN

Rich,
Thank you for the follow up! I'm sure it will be helpful to others.
Greg Martin
Sage
Copper Contributor
Posts: 72
Country: USA

Re: Accessing Sage Via VPN

Which VPN do you use and has it been error free?  We would lke ther same mehod..but have found inconsistencies...