Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT not releasing RAM?

Copper Contributor
Posts: 67
Country: USA

ACT not releasing RAM?

Hello - I'm running Act! Pro Version 18.1.103.0, Update 3  on a win10 machine, just recently (like in the last week or so) the ACT instance itself (as seen in task manager) has been running high RAM useage - enough so that it runs out of memory (an error is thrown by ACT).  It seems to build up over time (starting at about 70 MB and going up from there).  Any ideas? I don't have the function in my ACTDIAG to change release timing - I already looked into that.


Thank you.

Administrator
Posts: 4,024
Country: United_Kingdom

Re: ACT not releasing RAM?

Hi dandw2,

 

We've recently become aware of two issues causing "Out of memory" errors in Act!, I'll summarize these below:

 

  • Defect D-05700 - The "Out of memory" error is displayed when using the Notes or History tab, and is often seen alongside a "Parameter is not valid" error. A large red cross can be seen in the Notes/History tab panel. (relevant thread)
  • Defect D-05628 - The "Out of memory" error is seen while using the Web Info tab, usually after viewing multiple contacts with this tab open.

Both of these defects are currently under investigation.

I'm sorry for the inconvenience this is causing.

Copper Contributor
Posts: 67
Country: USA

Re: ACT not releasing RAM?


Gary W wrote:

Hi dandw2,

 

We've recently become aware of two issues causing "Out of memory" errors in Act!, I'll summarize these below:

 

  • Defect D-05700 - The "Out of memory" error is displayed when using the Notes or History tab, and is often seen alongside a "Parameter is not valid" error. A large red cross can be seen in the Notes/History tab panel. (relevant thread)
  • Defect D-05628 - The "Out of memory" error is seen while using the Web Info tab, usually after viewing multiple contacts with this tab open.

Both of these defects are currently under investigation.

I'm sorry for the inconvenience this is causing.


Ok, thank you for the reply - seems as though this is a problem across all versions of the program. I just checked, my RAM usage has gone from a manageable 70mb to 395 MB in the course of a couple hours. I imagine I'll get the out of memory error shortly.  I don't use web info tab - just schedule and history mostly.

Copper Contributor
Posts: 67
Country: USA

Re: ACT not releasing RAM?

I wanted to see how fast the RAM was being horded.  so it less than 2.5 hours, i went from 70 MB of RAM usage to 550 MB of RAM usage. I even had a conference call in that time, so wasn't using the application much.

Copper Contributor
Posts: 67
Country: USA

Re: ACT not releasing RAM?


dandw2@hotmail.com wrote:

I wanted to see how fast the RAM was being horded.  so it less than 2.5 hours, i went from 70 MB of RAM usage to 550 MB of RAM usage. I even had a conference call in that time, so wasn't using the application much.


now, about 45 minutes later, with heavier use - 802 MB RAM. unbelievable it's not releasing the memory.

Copper Contributor
Posts: 8
Country: Germany

Re: ACT not releasing RAM?

My clients also get this error from time to time.

 

Any news in this case?

 

 

19.1.63.0 Pro German

 

Moderator
Posts: 451
Country: United_Kingdom

Re: ACT not releasing RAM?

Hi @actuser67161

 

We had applied fixes for this issue in Service Pack 2 for V19. At this time the German client has not and most likely will not be updated to v19.2.

I am not presently aware if we will be providing an update to 19.1 which will resolve this issue but i believe it will be included in the next major update we provide for our German customer base

Copper Contributor
Posts: 8
Country: Germany

TrimRAMInterval missing in german config?

 

 

 

Act!.exe.config (2017/06/15 16:30) in german version contains no TrimRAMInterval.(identically with Act!DE.exe.config inside act1910update5.exe).

 

However Act!.exe.config inside act1910update5.exe contains it.

 

Added a value of 60 manually on client and observe it the next days.