Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT host machine cannot modify database share option

Accepted Solution Solved
New Member
Posts: 2
Country: USA
Accepted Solution

ACT host machine cannot modify database share option

My overall problem is that suddenly we were unable to access one of three databases from a remote machine.  We get the 

"Cannot find supplemental files...." error.  I have been through many knowledge base articles and nothing seems to work.

 

One key thing:  In the db that doesn't work if I go to "Database Maintenance" and click on the "Share Database" option (as administrator) I get a pop up warning about the dangers of sharing a database, but when I click OK nothing happens.  No check mark next to the Share option.  The two db that work both show the check mark.  I feel like I have tried everything but am willing to retry anything. 

 

I have ACT 2010 on a win7 machine.  I have turned the firewall off and disabled the anti-virus.

 

Any suggestions?

 

Gary

webmaster@foxvalleyrestore.org


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
New Member
Posts: 2
Country: USA

Re: ACT host machine cannot modify database share option

I did use run as administrator, which allowed me to click on the sharing option, but nothing happened.  

 

Today however I did a backup of my data, and restored it to new name.  Again, I ran as administrator, clicked the share option and this time it worked.   The machine that hosts all the databases is full of multiple instances of the same database.  My theory was to create something that had only one instance (name).  I suspect I had multiple shares that were corrupting the sharing but it just wasn't obvious.

 

Anyway, now it works.  My next step is to go through the host machine and do a massive (careful) cleanup.

 

Thanks for your input.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT host machine cannot modify database share option

Start ACT! by rick-clicking on the ACT! icon and "run As Administrator".
Then try sharing
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
New Member
Posts: 2
Country: USA

Re: ACT host machine cannot modify database share option

I did use run as administrator, which allowed me to click on the sharing option, but nothing happened.  

 

Today however I did a backup of my data, and restored it to new name.  Again, I ran as administrator, clicked the share option and this time it worked.   The machine that hosts all the databases is full of multiple instances of the same database.  My theory was to create something that had only one instance (name).  I suspect I had multiple shares that were corrupting the sharing but it just wasn't obvious.

 

Anyway, now it works.  My next step is to go through the host machine and do a massive (careful) cleanup.

 

Thanks for your input.