Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! and Outlook

New Member
Posts: 8
Country: USA

Re: ACT! and Outlook

Act 2007 doesn't work with Outlook 2000 properly

Act 2007 doesn't work with Outlook 2007 at all.

 

These are the two most popular versions of Outlook around... we had to jump through hoops to get our hands on 2003 to get around this lame ass problem.

 

If you're going to play the "Software YYYY" game, you should at least be compatible with the other programs in the same YYYY.

 

This is stupid on the part of Sage, one of the MANY reasons to hate this program.