Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT!Pro 2011 won't start

New Member
Posts: 6
Country: USA

ACT!Pro 2011 won't start

Greetings all!  I am using ACT!Pro 2011 hot fix 2; Vista Business 32bit; when I go to start ACT! I get the following error:

 

Resolution of the dependency failed, type= "Act.UI.ActApplication",
name= "".Exception message is: The current build operation
(build key Build Key[Act.UI.ActApplication, Null]) failed: Value of 'null' is not valid
for 'stream'. (Strategy type BuildPlanStrategy, index 3)

 

I have uninstalled and reinstalled. The same error still appears, and ACT! won't open. HELP!

 

It seems that one of the solutions floating around out there for an error like this is to rebuild preferences. Sounds good. In the knowledgebase I am told to backup my database. How do I backup my database when I can't open ACT!?

 

I am open to other suggestions on how to resolve the error too?  thanks!

 

P.

Copper Super Contributor
Posts: 78
Country: Australia

Re: ACT!Pro 2011 won't start

Type in services.msc in the Run Menu. Stop the SQL ACT7 instance. Type in Actdiag, find out where you database is located, copy the files to a backup location. But honestly, you don't need to worry about doing a backup. If you're just deleting preferences, they have nothing to do with the database.

Platinum Elite Contributor
Posts: 14,387
Country: Australia
Nickel Contributor
Posts: 173
Country: Australia

Re: ACT!Pro 2011 won't start

this is a problem with ACT Preferences, you can fix by following these instructions from the Sage Knowledgebase: http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2586...
Travis Rosevear ACC for
Act Today Australia and New Zealand
New Member
Posts: 20
Country: USA

Re: ACT!Pro 2011 won't start

I have done every single fix I've found on this thread, except for the rename fix. My computer won't allow me to rename the file. It says it's in use somewhere, even though every windows application and act are closed. I'm using ACT! Pro 2011 with Windows 7. The database is stored on a server running Window Server 2003 and it's used by three userstations all runing windows 7.

Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: ACT!Pro 2011 won't start

Try running ACT! 'As Administrator' first. To do this: right click on the ACT! icon > select 'Run As Administrator'. If that does not resolve it, try running Windows Explores as Admin (or turning off UAC) and see if you can rename it.
New Member
Posts: 20
Country: USA

Re: ACT!Pro 2011 won't start

Hi Mike,

 

Neither of those fixes are working. 

Highlighted
Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: ACT!Pro 2011 won't start

Can you still not delete/rename the dependant file?

 

Did you turn off UAC?

 

Try getting the new ACTDIAG from this ACT! Knowledge Base article -

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2760...

 

It will run from the Desktop.

 

Under the Tools Menu - Delete ACT! Preferences

New Member
Posts: 20
Country: USA

Re: ACT!Pro 2011 won't start

Hi Mike,

 

I still can't rename the file. UAC is off on the user's computer and on the server. I run the server as the administrator so I'm running explorer as the admin (i've double checked this as well). I've already deleted the user's preferences and the preferences on the server, but this has not fixed it. I have the new ACTDIAG. Is there anything left to do besides uninstall/reinstall?

Platinum Elite Contributor
Posts: 14,387
Country: Australia

Re: ACT!Pro 2011 won't start

This shouldn't be anything to do with the server... Also, there is no UAC in Windows 2003, only Vista, Win7 and Server 2008

 

For some reason, Vista has a lock on the file and ACT! needs to access it to run.

 

Try this on the problem PC:

As per: http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-system-file-in-windows-vista/


Start

CMD

Right-click Command Prompt, and choose Run as Administrator.
Type the following command, and then press ENTER:

takeown /f "%APPDATA%\ACT\ACT Data\DependentDlls.xml"

 
Type the following command, and then press ENTER to grant administrators full access to the file:

icacls /f "%APPDATA%\ACT\ACT Data\DependentDlls.xml" /GRANT ADMINISTRATORS:F

 

Then try to delete the XML file

If that doesn't work, try to delete the file in Safe Mode.

 

If still doesn't work, run

CHKDSK c: /f

 

Try again