Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT Permissions error

Accepted Solution Solved
New Member
Posts: 4
Country: United_Kingdom
Accepted Solution

ACT Permissions error

Hi,

 

I have a client who has 4 users wishing to connect to ACT.

 

2 are local and 2 are remote.

 

I have setup VPN router for the remote users.

 

The problem that i am having is when I initially shared the database on their server and gave it full permissions for everyone and each user i was getting the error message below

 

When i made a user a member of administrators on the server it would connect to the database without the permissions error, but when I use a standard user it does not and I get the message again. I can also connect using the administrator account and it works ok.

 

Stranger still when I do the same with the remote users not even the administrator account can connect to the database over the VPN with the same permissions message appearing.

 

Customer setup:

 

Act database running on SBS 2011

Clients are all Windows 7/Vista

 

VPN connects ok and I can browse folders on the server over VPN.

The message says it has found the database ok (so no worries about DNS as such), but does not have the correct permissions to connect ?

 

I have disabled firewall on both the server and clients and made sure sharing is set on the database and everyone has full control of the database folder.

 

Running out of ideas !

 

sageerror.jpg


Accepted Solutions
Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT Permissions error

Here is an article with instructions which should resolve your issue: KB Article 19876

 

There is a section specifically for 'File and Print' sharing, try it first.  If it doesn't resolve the issue, continue with the other options.

Greg Martin
Sage

View solution in original post


All Replies
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT Permissions error

Hello Cneville,

Welcome to the Sage ACT! Online Community!

 

As the message indicates, this is a permissions based issue.  Along with adding Everyone/Full Control, here are 2 options that have been used to resolve this:

- Create a matching Windows user name on the server

- Disable Password Protected File Sharing on the server

Greg Martin
Sage
New Member
Posts: 4
Country: United_Kingdom

Re: ACT Permissions error

Thanks Greg,

 

Just to clarify.

 

I need to change the remote users server username to match their windows username and password ?

 

Where and how do i disable the password protected file sharing on the server ?

 

Thanks again

New Member
Posts: 4
Country: United_Kingdom

Re: ACT Permissions error

I have it sorted now.

 

Turns out all I had to do was store the users server credentials on their Windows machines so that everytime they connect to the server via VPN and then Sage Act it would use these to login.

 

Fixed.

 

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT Permissions error

Thank you for the update.  Glad to hear it is working!

Greg Martin
Sage
New Member
Posts: 4
Country: United_Kingdom

Re: ACT Permissions error

Hi - I have a similar problem (ie. can see the database but it says we do not have sufficient share permissions).  We are not using vpn, just connecting using the pad file.  Am I possibly correct in thinking the only way to access the sage database (2013 pro) on a vm server is to set up a vpn connection?  I had hoped we could just access it using the updated pad file which shows the ip address of the server. Any help greatly appreciated!  Julie

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT Permissions error

Hello Juliejm,
Welcome to the Sage ACT! Online Community!

Can you provide the message you receive when you attempt to open the database?
Greg Martin
Sage
New Member
Posts: 4
Country: United_Kingdom

Re: ACT Permissions error

Thanks for our reply...i am driving at the minute but my error msg is the same at the image on this thread. Only sifference of course is the ip and db name. Ive even enabled the folder yo not require a login and added sage act files to firewall. I can access it from within the server juat not from an external pc. It sees it but says share permissions ... just like the above. I can still provide a screenshot but it will be ltr before. Its the same msg tho!!
New Member
Posts: 4
Country: United_Kingdom

Re: ACT Permissions error

Hi - I was unable to get a screen shot due to the remove access, however this is exactly what the message says:

 

The “31.25.191.130” computer and “CR_Systms” database were found but you do not have the appropriate share permissions to access the \\CRANSAA7\CR_Systems-database files folder on the “31.25.191.130” computer.  You may need to enable “File and Print Sharing” in the firewall of the 31.25.191.130 computer. Checking your Windows file share permissions may resolve this issue.

 

Do you have any ideas on how to resolve this, any help is hugely appreciated!!

Solution
Accepted by gmartin (Platinum Super Contributor)
‎09-25-2015 03:20 AM
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT Permissions error

Here is an article with instructions which should resolve your issue: KB Article 19876

 

There is a section specifically for 'File and Print' sharing, try it first.  If it doesn't resolve the issue, continue with the other options.

Greg Martin
Sage