Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

New Member
Posts: 7
Country: USA

ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

I tried to launch ACT! by Sage 2010 Version 12.1.181.0, Hot Fix 1 today and got the following error message. I could not find a solution online. Does anyboday have an idea how to fix this?

 

System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:28952.

 

Server stack trace:

 

at System.Net.Sockets.Socket.Connect(IPAddress[] addresses, Int32 port)
at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(AddressFamily family)
at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

 

Exception rethrown at [0]:

 

at Act.Application.Interop.ActApplicationInterop..ctor()
at Act.Application.Act.Main(String[] args)

Jeff Meyers
WindowsXP7Support.com
Jeff.Meyers@WindowsXP7Support.com
619-955-6246
Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

Hello Jeff,

Welcome to the Sage ACT! Online Community!

 

Can you provide some additional information:

- Operating system

- Is database physically on this machine, or hosted (shared database)

- If shared, do other users have the same issue

 

Possible causes:

- Service 'SQL Server (ACT7)' not started

- Service 'SQL Server Browser' not started (if shared database)

- Firewall blocking (exceptions: KB Article 25125)

 

 

Greg Martin
Sage
Nickel Elite Contributor
Posts: 934
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

Make sure SQL Server ( ACT 7 )  service is Started

Start

Run

Services.msc

Scroll down the list until you see it. Double click the item to modify/Start it.. Cheers - FSB

 

Bill Williams - Owner/Consultant/Trainer at Fill Staff "ACT! FOR RECRUITERS"
Manage Your ACT! Backups http://fillstaff.com/backupfolderspro.html - FREE
BIG ACT! LAYOUTS for Larger Monitors www.bigactlayouts.com
Protect your Files & Folders with Folder Lock Pro by New Software http://download.cnet.com/Folder-Lock/3000-2092_4-10063343.html
New Member
Posts: 7
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

[ Edited ]

Hi Bill,

 

Thank you for taking the time to respond to my request. I started the SQL Server (ACT7) service. It was set to automatic. When I tried to launch the application, I received the same error message. Let me look at the other response I received from the Community and I will get back with you.

 

I noticed in your signature that you are the President of Fill Staff.  I'm wondering if it would be feasible to work together?

 

[Edit: Removed personal information.  Please use Private Notes for this type of communication; click on Community user name and select 'Send a Private Message' option.]

 

Best regards and, again, thank for your time and efforts!

 

Jeff Meyers

 

I n

 

Jeff Meyers
WindowsXP7Support.com
Jeff.Meyers@WindowsXP7Support.com
619-955-6246
New Member
Posts: 7
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

Hi Greg,

 

Thanks for taking the time to respond to my request.

 

I'm using ACT! on a single PC running Windows 7 Pro SP1.

 

I must assume that the database is physically on this machine as the program was working a short while ago.

 

I'm using ZoneAlarm Anti-Virus and also have SpyShelter Personal and WinPatrol installed on my PC. Both of these programs had never before caused any conflicts with ACT!.

 

SQL Server (ACT7) had been set to Automatic, so I started the service but received the same error message when I tried to re-launch ACT! SQL Server Browser is currently set to 'Disabled'.

 

Please let me know if you need any additional informaiton and, again, thank you for your response. 

 

Best regards,

 

Jeff Meyers

(619) 955-6246

Jeff Meyers
WindowsXP7Support.com
Jeff.Meyers@WindowsXP7Support.com
619-955-6246
New Member
Posts: 7
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

Greg,

 

Another respondant to this issue, Bill Williams, discovered that my ACT folder was not in the My Documents folder. We moved it but that did not clear up the problem. Bill suggested thtat I locate a download link for ACT! 2010 Diagnostic Tool. I couldn't find one in the Community. Have you any idea where or how I might acquire the download? I do not have an ACT! 2010 disk as I purchased a downloadable version of the applicaiton. Also, do you know if there are any free tools or ways to hack or reset passwords in ACT!?

 

Many thanks,

 

Jeff

Jeff Meyers
WindowsXP7Support.com
Jeff.Meyers@WindowsXP7Support.com
619-955-6246
Bronze Super Contributor
Posts: 1,679
Country: Australia

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

ActDiag can be found here: http://kb.sagesoftwareonline.com/app/answers/detail/a_id/27607/

Just reading the thread, I'd be inclinded (and you may have already done these) make sure that you're logged in as a Windows Admin, run ACT! as Administrator.

I'd turn off AV & Firewalls (updates to them can interfere with SQL) temporarily to test, if it works, we've located the issue, then to fix it Smiley Happy

At a guess, I'd say that possibly a Windows Update (to SQL) might have changed the SQL Port being used. ActDiag will show you which port is used (ActDiag | Server | Server Security | TCP/IP Port). Make sure that this port is allowed by the firewall.

 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

To add to Ben's comments, I would also suspect the anti-virus software.  Here is an article with exceptions to add to the a/v software: KB Article 25125

Greg Martin
Sage
New Member
Posts: 7
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

Thanks Greg ... At this point, I'm just going to reinstall the applicaiton. I do appreciate the great support!
Jeff Meyers
WindowsXP7Support.com
Jeff.Meyers@WindowsXP7Support.com
619-955-6246
New Member
Posts: 7
Country: USA

Re: ACT ERROR: No connection could be made because the target machine actively refused it 127.0.0.1:28952

Ben,

Thanks for you time and support!

I downloaded the the diagtool but it wouldn't run for some reason. Does one need to install the .dll file that was listed along with the diagtool download in order for it to work?
Jeff Meyers
WindowsXP7Support.com
Jeff.Meyers@WindowsXP7Support.com
619-955-6246