Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2010 "The database (name) could not be accessed"

Accepted Solution Solved
New Member
Posts: 3
Country: United States
Accepted Solution

ACT! 2010 "The database (name) could not be accessed"

Using Act! with Windows 7 64bit operating system - upon opening up Act! I am prompted for username and password - won't let me open my database.  I restored database with a different name and it works BUT only when I sleep or hibernate Windows.  When I restart windows it asks me for the username and password and won't let me log into my database again.

 

Is this a BUG in Windows 7?

 

Single user on laptop.


Accepted Solutions
Solution
Accepted by topic author brianrob1
‎09-25-2015 03:20 AM
Nickel Elite Contributor
Posts: 508
Country: USA

Re: ACT! 2010 "The database (name) could not be accessed"

when you get that error, go to Start>Run and type in services.msc, which will bring up the Windows Services interface.  Scroll down to the "S"-es and look for the ACT7 instance of SQL Server.  It should be "Start"-ed.  If not, that could be an issue, SQL Server is not starting properly on a reboot.  A related issue in the past few months has been an update from Microsoft for SQL Server. Check your automatic updates, and if there's a service pack for SQL Server, uncheck it, you don't need it.  What was happenning is that the update could not install properly, and would Stop SQL Server, which sounds like what's happenning.  Hope this helps...
Richard Brust
ACT! Certified Consultant
richard@rbrDataSolutions.com

View solution in original post


All Replies
Solution
Accepted by topic author brianrob1
‎09-25-2015 03:20 AM
Nickel Elite Contributor
Posts: 508
Country: USA

Re: ACT! 2010 "The database (name) could not be accessed"

when you get that error, go to Start>Run and type in services.msc, which will bring up the Windows Services interface.  Scroll down to the "S"-es and look for the ACT7 instance of SQL Server.  It should be "Start"-ed.  If not, that could be an issue, SQL Server is not starting properly on a reboot.  A related issue in the past few months has been an update from Microsoft for SQL Server. Check your automatic updates, and if there's a service pack for SQL Server, uncheck it, you don't need it.  What was happenning is that the update could not install properly, and would Stop SQL Server, which sounds like what's happenning.  Hope this helps...
Richard Brust
ACT! Certified Consultant
richard@rbrDataSolutions.com
New Member
Posts: 3
Country: United States

Re: ACT! 2010 "The database (name) could not be accessed"

[ Edited ]

I found the ACT7 instance of SQL Server and paused it.  I closed ACT! and reopened it and was able to duplicate the problem.  I closed ACT!, unpaused the instance of SQL Server and it opened up my database with no problem.  THANK YOU!

 

One more thing  I looked into the automatic updates and I found "Security Update for SQL Server 2005 Service Pack 3 (KB970892)" how do I "uncheck" it so it does not interfere with the ACT7 instance of SQL Server?

 

Best regards,

 

Brian Robinson

Message Edited by brianrob1 on 01-07-2010 04:15 PM
Nickel Elite Contributor
Posts: 508
Country: USA

Re: ACT! 2010 "The database (name) could not be accessed"

On my machine, which is Vista Home Premium, I get a yellow "shield" in the icon tray when updates are available.  Clicking on that icon, I actually start the update wizard/process.  A screen, or two, into it, I get a list of the updates that it's trying to install, and that's where I can uncheck them.

 

I guess another important point is that I have it set to "Download updates but let me to choose whether to install them"  This is in the windows update settings interface.  Hope this helps...

Richard Brust
ACT! Certified Consultant
richard@rbrDataSolutions.com
New Member
Posts: 3
Country: United States

Re: ACT! 2010 "The database (name) could not be accessed"

Here's the final chapter in this story...I actually had to uninstalled the SQL security update to keep this error from occurring anymore.