Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2010 SP1 breaks Outlook email integration

Copper Contributor
Posts: 99
Country: USA

ACT! 2010 SP1 breaks Outlook email integration

So far today, I have had 3 clients call after installing the ACT! 2010 Standard Service Pack 1 upgrade.  In all 3 cases, the integration with MS Outlook broke after installing SP1.  Two were using Outlook 2007 and one was on Outlook 2003.  All three had been working perfectly prior to installing SP1.

 

The ACT! address books were still showing in Outlook, and the Add-in was still showing as installed and not disabled in Outlook.  But the ACT! icons did not appear in Outlook.

 

I contacted tech support and the agent remoted into one of the machines, and verified that it was not working.  He removed the ACT! address book from Outlook, then removed it from ACT! and un-selecting Outlook as the email program. Then he re-added the ACT! address book from within Outlook, and added Outlook back as the default program in ACT!  This fixed the issue.  

 

I then installed the update on my computer, and the same thing happened - no ACT! integration in Outlook, and clicking an email address from within ACT! produced an error saying that the server threw an exception.  Repeating the process that tech support went through fixed the issue on my machine also.

 

I'm sure there will be a flood of tech support calls over the days ahead - but at least now you know how to fix it if it happens to you.

 

 

Best Regards,


Chuck
Copper Contributor
Posts: 99
Country: USA

Re: ACT! 2010 SP1 breaks Outlook email integration

Had 2 more clients call with the same issue this morning, so it is not an isolated issue.....
Best Regards,


Chuck
Copper Contributor
Posts: 99
Country: USA

Re: ACT! 2010 SP1 breaks Outlook email integration

A friend who uninstalled ACT! 2010 first and then did a complete install of 2010 with SP1/HF1 already applied (complete build from the ACC site) had no problems - it only seems to happen when installing the SP1/HF1 update on an existing 2010 installation.
Best Regards,


Chuck
Copper Contributor
Posts: 6
Country: United States

Re: ACT! 2010 SP1 breaks Outlook email integration

I have what I believe to be a similar issue. After installing SP1 on an existing ACT 2010 installation, when starting Microsoft Outlook 2007, I get the following error message:

 

Assertion Failed.

PopulateAddressStruct::Not SMTP Address and not Distribution List

 

at MessageReader.....

 

When I hit the "Ignore" option, I get an Act.Outlook.Service.exe - No debugger found error. As Chuck has found, I am able to eventually get into Outlook with my address book. I am also using DoubleLook, which also does not seem to be working correctly after the update.

 

 

Copper Contributor
Posts: 6
Country: United States

Re: ACT! 2010 SP1 breaks Outlook email integration

Update: Called customer service at Sage. They were great to work with. After disabling all the add-ins and several iterations to triage the problem, it came down to the Act.Outlook.Service.exe file causing the problem when opening Outlook. They reinstalled Act with a package including the SP1 HF1 and everything works smoothly as Chuck mentioned above (thx Chuck for the tip).

 

Tuned Listener
Posts: 25
Country: United States

Re: ACT! 2010 SP1 breaks Outlook email integration

Thanks for the post. I tried your solution and am still getting an error when sending email from Outlook:

 

Method not found: ‘Boolean Act.Outlook.Service.Interfaces.IHistoryXMLWriterService.CreateHistoryXMLFile(System.String,System.String,Act.Outlook.Service.OutlookHistoryType,Act.Outlook.Service.Interfaces.HistoryFormatOptions, Boolean, Boolean, Boolean,Boolean, Act.Outlook.Service.Interfaces.QuickAtachContactType, Boolean,Act.Outlook.Service.Interfaces.IContact[],Act.Outlook.Service.Interfaces.IDatabaseInfo, ActOutlook90.HeaderStruct)’ 

 

Thanks!

 

Rick Ayres

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! 2010 SP1 breaks Outlook email integration

Hello Rick,

I'm sorry to hear about the issue you are having with ACT! and Outlook after applying the ACT! 2010SP1 update. Please see your Private Messages in this forum.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Tuned Listener
Posts: 25
Country: United States

Re: ACT! 2010 SP1 breaks Outlook email integration

Hi Greig,

 

I've reinstalled ACT! and still having very quirky behavior. Outlooks keeps saying the ACT address book is not properly configured, and won't fix properly. And ACT is no longer starting again. Any help would be very much appreciated as I can't get to my contacts and have a lot of calls to make Monday.

 

Rick Ayres

Lakes Print 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! 2010 SP1 breaks Outlook email integration

Rick,

I'm sorry to hear that you are still having the issues with ACT! and Outlook. We'll do our best to help you with this. Please see your Private Messages.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 43
Country: USA

Re: ACT! 2010 SP1 breaks Outlook email integration

Hello Mr. Greig Hollister I have a client with the same exact problem. How do I fix this issue?

 

Thanks in advance!